Bug 1303511 - update copyright of license.txt file in virtio-win to 2016
update copyright of license.txt file in virtio-win to 2016
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.3
Assigned To: Yash Mankad
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-01 01:55 EST by lijin
Modified: 2016-11-04 04:50 EDT (History)
9 users (show)

See Also:
Fixed In Version: virtio-win-1.9.0-3.el7
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 04:50:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lijin 2016-02-01 01:55:46 EST
Description of problem:
Copyright of virtio-win_license.txt displays as "2015":
"Copyright (C) 2009, 2015 Red Hat, Inc. and/or its affiliates."
Please update it to "2016".

Version-Release number of selected component (if applicable):
virtio-win-1.7.5-0.el6

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 4 Yash Mankad 2016-06-10 13:41:42 EDT
Fixed in version virtio-win-1.8.0-5.el7
Comment 8 Yu Wang 2016-07-04 02:05:54 EDT
Hi,

QE have checked the copyright for 1.8.0-5, but it shows "Copyright (C) 2009, 2015, 2016 Red Hat, Inc. " in licences.txt, I think It should be "Copyright (C) 2009, 2016 Red Hat, Inc." 

I would like to confirm with you ,is that right?


Thanks
Yu Wang
Comment 9 Yash Mankad 2016-07-06 14:45:34 EDT
Hi,

I am unsure of why it should be removed?

My opinion was to not remove the existing copyright version
as there were already two (2009, 2015). So I decided to add
to the line and not update it.

Could you kindly clarify as to why it should be "Copyright (C) 2009, 2016"
and not "Copyright (C) 2009, 2015, 2016" ?

Thanks,
Yash
Comment 10 Yu Wang 2016-07-06 22:10:49 EDT

(In reply to Yash Mankad from comment #9)
> Hi,
> 
> I am unsure of why it should be removed?
> 
> My opinion was to not remove the existing copyright version
> as there were already two (2009, 2015). So I decided to add
> to the line and not update it.
> 
> Could you kindly clarify as to why it should be "Copyright (C) 2009, 2016"
> and not "Copyright (C) 2009, 2015, 2016" ?
> 
> Thanks,
> Yash

Hi,

It has the copyright of 2015, and your thought is right. But it seems that the copyright before was wrong, I think it should be "Copyright (C) 2009-2016". Could you help to confirm whether I thought is right?

Thanks
Yu Wang
Comment 11 Yu Wang 2016-07-08 02:21:11 EDT
pls see comment#10

Thanks
Comment 12 Yash Mankad 2016-07-11 16:14:03 EDT
Based on the discussion with an in-house counsel, we can either keep it as it is or change it to "Copyright (C) 2009 Red Hat .. ". I am in favor of the latter option, so that we do not need to update it every year.

In either case, I will not be redoing the builds that have the current format. I will update the file, if required, based on your reply.
Comment 13 Yu Wang 2016-07-11 20:05:19 EDT
(In reply to Yash Mankad from comment #12)
> Based on the discussion with an in-house counsel, we can either keep it as
> it is or change it to "Copyright (C) 2009 Red Hat .. ". I am in favor of the
> latter option, so that we do not need to update it every year.
> 
> In either case, I will not be redoing the builds that have the current
> format. I will update the file, if required, based on your reply.

Thanks, Yash, I also think the latter option is ok.

BR
Yu Wang
Comment 14 Yu Wang 2016-07-12 23:01:31 EDT
Hi Yash,

I have a question, for virtio-win-prewhql build, our copyright is "Copyright (C) 2009-2016", could you please help to check if it should be the same as "license.txt" file in virtio-win-1.8.0-5.el7?

pls refer to Bug 1303510 - Change the copyright on all the Windows drivers to "2016" in virtio-win-prewhql build.

Thanks
Yu Wang
Comment 15 Yu Wang 2016-07-13 04:28:22 EDT
Hi,

Sorry, supplement for comment#14, virtio-win-prewhql build ,I mean the copyright in .sys, .inf,.cat file is "Copyright (C) 2009-2016".

Thanks
Yu Wang
Comment 16 Yash Mankad 2016-07-13 17:02:24 EDT
Hi Yu,

As discussed with the in-house counsel, there is no standard convention and the legal significance is extremely low. The file "license.txt" is a variant of the Red Hat end user license agreement and the copyright notice in the footer in these licenses is not really intended to refer to the software, which might not be the case for the virtio-win-prewhql build. 

So, I recommend that we leave the copyright as "Copyright (C) 2009-2016" for the virtio-win-prewhql build. 

Thanks,
Yash
Comment 17 lijin 2016-09-17 23:21:54 EDT
check the file in virtio-win-1.9.0-2.el7.noarch :
"Copyright (C) 2009, 2015, 2016 Red Hat, Inc. and/or its affiliates.“

It's a little strange that only 2009,2015,2016 is listed,it maybe lead people to believe we only have copyright in these three years,what about years between 2009 to 2015?

I think following display as you discussed before are all acceptable:
Copyright (C) 2009 Red Hat, Inc.
Copyright (C) 2009,2016 Red Hat, Inc.

Anyway,it may not be worthy to re-build an virtio-win rpm package.
What's your opinoin,Yash?
Comment 18 Yash Mankad 2016-09-19 10:18:56 EDT
(In reply to lijin from comment #17)
> check the file in virtio-win-1.9.0-2.el7.noarch :
> "Copyright (C) 2009, 2015, 2016 Red Hat, Inc. and/or its affiliates.“
> 
> It's a little strange that only 2009,2015,2016 is listed,it maybe lead
> people to believe we only have copyright in these three years,what about
> years between 2009 to 2015?
> 
> I think following display as you discussed before are all acceptable:
> Copyright (C) 2009 Red Hat, Inc.
> Copyright (C) 2009,2016 Red Hat, Inc.
> 
> Anyway,it may not be worthy to re-build an virtio-win rpm package.
> What's your opinoin,Yash?

Hi Li Jin,

I will update it to

Copyright (C) 2009 Red Hat, Inc.

based on the input from the in-house counsel.
Thanks for catching this one.

Yash
Comment 19 Yash Mankad 2016-09-19 11:28:48 EDT
Fixed in version virtio-win-1.9.0-3.el7
Comment 20 lijin 2016-09-19 21:19:42 EDT
check in virtio-win-1.9.0-3.el7,this issue has been fixed.
"Copyright (C) 2009 Red Hat, Inc. and/or its affiliates. "

Thanks,Yash
Comment 22 errata-xmlrpc 2016-11-04 04:50:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2609.html

Note You need to log in before you can comment on or make changes to this bug.