Bug 1303573 - RequestedAuthnContext - Comparison attribute is added as a child element
RequestedAuthnContext - Comparison attribute is added as a child element
Status: CLOSED DUPLICATE of bug 1310860
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lasso (Show other bugs)
7.2
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Simo Sorce
Namita Soman
:
Depends On: 1310860 1404295
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-01 05:53 EST by Travers Carter
Modified: 2016-12-13 09:51 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-15 11:13:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Travers Carter 2016-02-01 05:53:40 EST
Description of problem:
When generating a AuthnRequest, adding a "RequestedAuthnContext" and setting the "Comparison" generates a <Comparison> node instead of adding a Comparison= attribute to the RequestedAuthnContext node

Version-Release number of selected component (if applicable):
lasso-2.5.0-1.el7.x86_64.rpm

How reproducible:
Always


Steps to Reproduce:
1. See upstream bugreport (with patch) at https://dev.entrouvert.org/issues/9616

Actual results:
<samlp:RequestedAuthnContext>
  .......
  <samlp:Comparison>minimum</samlp:Comparison>
</samlp:RequestedAuthnContext>

Expected results:
<samlp:RequestedAuthnContext comparison="minimum" >
  .......
</samlp:RequestedAuthnContext>


Additional info:
The patch for this issue has been accepted upstream, please consider adding this patch.
Comment 3 John Dennis 2016-06-09 18:17:52 EDT
This is fixed by upstream commit 675858f4 which is part of Lasso 2.5.1
Comment 4 John Dennis 2016-06-15 11:13:34 EDT

*** This bug has been marked as a duplicate of bug 1310860 ***

Note You need to log in before you can comment on or make changes to this bug.