Bug 1303600 - unable to open setup networks dialog
unable to open setup networks dialog
Status: CLOSED DUPLICATE of bug 1297490
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Yevgeny Zaspitsky
Pavel Stehlik
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-01 07:16 EST by Martin Mucha
Modified: 2016-02-10 14:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-01 13:50:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 52922 master DRAFT webadmin: unable to open setup networks dialog due to unboxing 2016-02-01 07:30 EST

  None (edit)
Description Martin Mucha 2016-02-01 07:16:16 EST
Description of problem:
unable to open setup networks dialog

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. clean 3.6 installation
2. NetworkExclusivenessPermissiveValidation has to be null (it is in my environment after clean install) 
3. open setup networks dialog.

Actual results:


Expected results:


Additional info:

unboxing error in:
org.ovirt.engine.ui.uicommonweb.dataprovider.AsyncDataProvider#isNetworkExclusivenessPermissiveValidation

probably easily fixable by returning:

return Boolean.TRUE.equals(getConfigValuePreConverted(
                ConfigurationValues.NetworkExclusivenessPermissiveValidation,
                version));
Comment 1 Yevgeny Zaspitsky 2016-02-01 13:50:10 EST

*** This bug has been marked as a duplicate of bug 1297490 ***

Note You need to log in before you can comment on or make changes to this bug.