Bug 1297490 - NPE is thrown in host setup networks dialog when trying configuring a host of higher version than the engine one
NPE is thrown in host setup networks dialog when trying configuring a host of...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.2
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.3
: 3.6.3.1
Assigned To: Yevgeny Zaspitsky
Michael Burman
:
: 1303600 1305892 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-11 11:06 EST by Yevgeny Zaspitsky
Modified: 2016-02-18 06:18 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:08:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: exception+
ylavi: planning_ack+
danken: devel_ack+
myakove: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 52926 master MERGED webadmin: use the cluster version rather than host one 2016-02-01 13:16 EST
oVirt gerrit 52943 ovirt-engine-3.6 MERGED webadmin: use the cluster version rather than host one 2016-02-02 04:44 EST
oVirt gerrit 52945 ovirt-engine-3.6.3 MERGED webadmin: use the cluster version rather than host one 2016-02-02 04:46 EST

  None (edit)
Description Yevgeny Zaspitsky 2016-01-11 11:06:04 EST
Description of problem:
NPE is thrown when trying configuring networks on a host with VDSM version higher than the engine one. That happens because the code tries to a config value for the host version, which is not exists in the engine DB (as that is considered as a future one relative to the engine), instead of checking cluster support level (which could not be unknown/new to the engine).

Version-Release number of selected component (if applicable):
engine 3.6
vdsm - master (4.0)

How reproducible:
100%

Steps to Reproduce:
1. Install a v4.0 host to engine 3.6
2. try to open setup networks dialog for the newly installed host
3.

Actual results:
The gear spins endlessly an NPE appears in the browser console log.

Expected results:
An exception should not be thrown and the dialog should appear flawlessly.

Additional info:
The NPE happens in org.ovirt.engine.ui.uicommonweb.models.hosts.network.NetworkOperationFactory:138 when trying cast the null value returned by AsyncDataProvider.isNetworkExclusivenessPermissiveValidation.
Comment 1 Yevgeny Zaspitsky 2016-02-01 13:50:10 EST
*** Bug 1303600 has been marked as a duplicate of this bug. ***
Comment 2 Michael Burman 2016-02-15 04:28:01 EST
Verified on - 3.6.3.1-0.1.el6 with vdsm-4.17.999-593.git2452685.el7.centos.noarch(nightly 4.0)
Comment 3 Yevgeny Zaspitsky 2016-02-18 06:18:46 EST
*** Bug 1305892 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.