Bug 1303643 - qt5-qtdeclarative-5.6.0-0.7.beta.fc24 broken
qt5-qtdeclarative-5.6.0-0.7.beta.fc24 broken
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt5-qtdeclarative (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
: 1303881 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-01 09:51 EST by Sandro Mani
Modified: 2016-02-04 09:40 EST (History)
9 users (show)

See Also:
Fixed In Version: qt5-qtdeclarative-5.6.0-0.8.beta.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-03 18:29:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sandro Mani 2016-02-01 09:51:26 EST
Description of problem:
qt5-qtdeclarative-5.6.0-0.7.beta.fc24 causes any Qt5+QML application to crash immediately on start:

$ valgrind qtcreator

==7839== Memcheck, a memory error detector
==7839== Copyright (C) 2002-2015, and GNU GPL'd, by Julian Seward et al.
==7839== Using Valgrind-3.11.0 and LibVEX; rerun with -h for copyright info
==7839== Command: qtcreator
==7839== 
==7839== Invalid read of size 8
==7839==    at 0x7BEFDDB: QV4::Object::defineDefaultProperty(QString const&, QV4::Value const&) (in /usr/lib64/libQt5Qml.so.5.6.0)
==7839==    by 0x7BF5AC0: ??? (in /usr/lib64/libQt5Qml.so.5.6.0)
==7839==    by 0x7BB3698: QV4::ExecutionEngine::ExecutionEngine(QV4::EvalISelFactory*) (in /usr/lib64/libQt5Qml.so.5.6.0)
==7839==    by 0x7CE6CA0: QV8Engine::QV8Engine(QJSEngine*) (in /usr/lib64/libQt5Qml.so.5.6.0)
==7839==    by 0x7B4203D: QJSEngine::QJSEngine() (in /usr/lib64/libQt5Qml.so.5.6.0)
==7839==    by 0x238395AF: Core::JsExpander::JsExpander() (in /usr/lib64/qtcreator/plugins/libCore.so)
==7839==    by 0x2381EB93: ??? (in /usr/lib64/qtcreator/plugins/libCore.so)
==7839==    by 0x2389F3D4: ??? (in /usr/lib64/qtcreator/plugins/libCore.so)
==7839==    by 0x2389F6B3: ??? (in /usr/lib64/qtcreator/plugins/libCore.so)
==7839==    by 0x4E5F83D: ExtensionSystem::Internal::PluginSpecPrivate::initializePlugin() (in /usr/lib64/qtcreator/libExtensionSystem.so.1.0.0)
==7839==    by 0x4E59869: ExtensionSystem::Internal::PluginManagerPrivate::loadPlugin(ExtensionSystem::PluginSpec*, ExtensionSystem::PluginSpec::State) (in /usr/lib64/qtcreator/libExtensionSystem.so.1.0.0)
==7839==    by 0x4E5A24C: ExtensionSystem::Internal::PluginManagerPrivate::loadPlugins() (in /usr/lib64/qtcreator/libExtensionSystem.so.1.0.0)
==7839==  Address 0x0 is not stack'd, malloc'd or (recently) free'd
==7839== 
==7839== 
==7839== Process terminating with default action of signal 11 (SIGSEGV)
==7839==  Access not within mapped region at address 0x0
==7839==    at 0x7BEFDDB: QV4::Object::defineDefaultProperty(QString const&, QV4::Value const&) (in /usr/lib64/libQt5Qml.so.5.6.0)
==7839==    by 0x7BF5AC0: ??? (in /usr/lib64/libQt5Qml.so.5.6.0)
==7839==    by 0x7BB3698: QV4::ExecutionEngine::ExecutionEngine(QV4::EvalISelFactory*) (in /usr/lib64/libQt5Qml.so.5.6.0)
==7839==    by 0x7CE6CA0: QV8Engine::QV8Engine(QJSEngine*) (in /usr/lib64/libQt5Qml.so.5.6.0)
==7839==    by 0x7B4203D: QJSEngine::QJSEngine() (in /usr/lib64/libQt5Qml.so.5.6.0)
==7839==    by 0x238395AF: Core::JsExpander::JsExpander() (in /usr/lib64/qtcreator/plugins/libCore.so)
==7839==    by 0x2381EB93: ??? (in /usr/lib64/qtcreator/plugins/libCore.so)
==7839==    by 0x2389F3D4: ??? (in /usr/lib64/qtcreator/plugins/libCore.so)
==7839==    by 0x2389F6B3: ??? (in /usr/lib64/qtcreator/plugins/libCore.so)
==7839==    by 0x4E5F83D: ExtensionSystem::Internal::PluginSpecPrivate::initializePlugin() (in /usr/lib64/qtcreator/libExtensionSystem.so.1.0.0)
==7839==    by 0x4E59869: ExtensionSystem::Internal::PluginManagerPrivate::loadPlugin(ExtensionSystem::PluginSpec*, ExtensionSystem::PluginSpec::State) (in /usr/lib64/qtcreator/libExtensionSystem.so.1.0.0)
==7839==    by 0x4E5A24C: ExtensionSystem::Internal::PluginManagerPrivate::loadPlugins() (in /usr/lib64/qtcreator/libExtensionSystem.so.1.0.0)



Version-Release number of selected component (if applicable):
qt5-qtdeclarative-5.6.0-0.7.beta.fc24

How reproducible:
Always


Additional info:
Possibly GCC6 related.
Comment 1 Sandro Mani 2016-02-01 10:44:48 EST
Rebuilding qt5-qtdeclarative-5.6.0-0.6.beta.fc24 with GCC6 also breaks it, so yes, it is related to GCC6.
Comment 2 Ngo Than 2016-02-01 10:46:55 EST
it looks like gcc6 miscompiled the codes again. I'm trying to build it with -O0 and checks if it works
Comment 3 Ngo Than 2016-02-01 16:10:37 EST
which platform did you test?
Comment 4 Sandro Mani 2016-02-01 16:12:03 EST
on x86_64
Comment 5 Ngo Than 2016-02-02 08:39:31 EST
*** Bug 1303881 has been marked as a duplicate of this bug. ***
Comment 6 Rex Dieter 2016-02-02 10:47:16 EST
We're guessing this may be due to gcc6 new behavior in, see
https://gcc.gnu.org/ml/gcc/2016-01/msg00184.html

In which case, we'll try (re)building Qt5 with -fno-delete-null-pointer-checks
Comment 7 Rex Dieter 2016-02-02 11:04:38 EST
%changelog
* Tue Feb 02 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.8.beta
- build with -fno-delete-null-pointer-checks to workaround gcc6-related runtime crashes (#1303643)
Comment 8 Ngo Than 2016-02-02 12:09:20 EST
it seems the compiler flag -fno-delete-null-pointer-checks will fix the miscompiled codes. We can use it as the workaround.

Sandro, could you please try the new build with this flag and give us the feebacks

http://koji.fedoraproject.org/koji/buildinfo?buildID=715479

Thanks
Comment 9 Sandro Mani 2016-02-02 12:11:29 EST
Yep, works, thanks!
Comment 10 poma 2016-02-03 00:24:58 EST
[NVA8/NV98] KDE Plasma locks up: Nouveau reports error "resource sanity check" "unable to handle kernel paging request"
https://bugs.freedesktop.org/show_bug.cgi?id=92892
Comment 11 Kevin Kofler 2016-02-03 18:27:56 EST
That upstream bug is a completely different issue.
Comment 12 poma 2016-02-04 09:34:43 EST
You are some kind of the Nouveau "expert"? :)

BTW Rawhide's KDE Live is B.R.O.K.E.N.
Who maintains that crap?
Comment 13 Rex Dieter 2016-02-04 09:40:54 EST
Please adhere to the fedora code of conduct.

Again, if you're trying interested in your issue being fixed, file a separate bug (nouveau bugs are not relevant to this report)

Note You need to log in before you can comment on or make changes to this bug.