Bug 1303660 - Broken Dependencies for python2-rsa-3.3-2.el6.noarch
Broken Dependencies for python2-rsa-3.3-2.el6.noarch
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: python-rsa (Show other bugs)
el6
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Yohan Graterol
Fedora Extras Quality Assurance
:
: 1303763 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-01 10:22 EST by edu.carlos.vieira
Modified: 2016-02-03 21:28 EST (History)
11 users (show)

See Also:
Fixed In Version: python-rsa-3.3-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-03 21:28:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description edu.carlos.vieira 2016-02-01 10:22:37 EST
Description of problem: The package is requiring python-pyasn1 >= 0.1.3 but the only available is python-pyasn1-0.0.12a-1.el6.noarch (CentOS-Base).


Version-Release number of selected component (if applicable): python2-rsa-3.3-2.el6


How reproducible: At package install 


Steps to Reproduce:
1. yum install python2-rsa

Actual results:

Error: Package: python2-rsa-3.3-2.el6.noarch (epel)
           Requires: python-pyasn1 >= 0.1.3
           Available: python-pyasn1-0.0.12a-1.el6.noarch (CentOS-Base)
               python-pyasn1 = 0.0.12a-1.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodiges


Expected results:

Package installed sucessfully.

Additional info:
Comment 1 Didier BONNEFOI 2016-02-01 11:10:58 EST
Hi,

I've got the same problem, this should only occurs on CentOS 6.

The required package python-pyasn1 >= 0.1.3 can only works on CentOS 7 which provides version 0.1.6

An if statement should be added in the Spec file to maintain compatibility with CentOS 6


Some week ago, the old package "python-rsa-3.1.1-5.el6" was working fine

For now, I'm blocked to install a package which depends on it

Regards
Comment 2 Tuomo Soini 2016-02-01 12:10:03 EST
Fix is simply:

-Requires:       python-pyasn1 >= 0.1.3
+Requires:       python-pyasn1%{!?el6: >= 0.1.3}
Comment 3 Anssi Johansson 2016-02-01 13:00:34 EST
This seems to cause problems for people installing cloud-init. For the record and for the benefit of people searching for a solution for this problem, installing the old version of python-rsa from https://kojipkgs.fedoraproject.org/packages/python-rsa/3.1.1/5.el6/noarch/ first and then installing cloud-init seems to work. No doubt that will cause problems with "yum update" later on, at least until this package is fixed.
Comment 4 Shaun Brady 2016-02-01 17:04:35 EST
This seems to cause problems for people installing python-boto.
Comment 5 Ian Wienand 2016-02-01 18:17:24 EST
There was a commit [1] which modified the build dependencies, but not the install dependencies [2].  Probably just accidentally missed?

[1] http://pkgs.fedoraproject.org/cgit/rpms/python-rsa.git/commit/?h=el6&id=d8e0163c3f7629c666cbf820ac3c81bf061c8eb7
[2] http://pkgs.fedoraproject.org/cgit/rpms/python-rsa.git/tree/python-rsa.spec?h=el6#n46
Comment 6 Ian Wienand 2016-02-01 18:20:32 EST
*** Bug 1303763 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2016-02-02 07:15:49 EST
python-rsa-3.3-3.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-16806dbf19
Comment 8 Fabio Alessandro Locati 2016-02-02 07:16:19 EST
I'm really sorry for what happened. I've fixed it and now the update is in bodhi
Comment 9 Fedora Update System 2016-02-02 19:21:32 EST
python-rsa-3.3-3.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-16806dbf19
Comment 10 Mark McKinstry 2016-02-03 15:31:32 EST
It has +3 karma now. I think it can be pushed to stable with +3 karma?
Comment 11 Fabio Alessandro Locati 2016-02-03 15:36:55 EST
No it can not.
In bodhi you can not "push to stable" but you can "ask for the update to be pushed in stable". For this update the thresholds were +1/-3 (so, the first +1 triggered the request), but a program (masher) has to actually push to stable this update (as well as many other updates that have required to be pushed in stable but have not yet been pushed to stable by masher. Usually masher runs every 24 hours, so it should run very soon for the EL6 branch.
Comment 12 Fedora Update System 2016-02-03 21:28:12 EST
python-rsa-3.3-3.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.