Bug 1303763 - Broken python-pyasn1 dependency on RHEL 6
Broken python-pyasn1 dependency on RHEL 6
Status: CLOSED DUPLICATE of bug 1303660
Product: Fedora EPEL
Classification: Fedora
Component: python-rsa (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Yohan Graterol
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-01 16:40 EST by Garrett Holmstrom
Modified: 2016-02-01 18:20 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-01 18:20:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Garrett Holmstrom 2016-02-01 16:40:42 EST
Description of problem:
python2-rsa-3.3-2.el6 requires python-pyasn1 >= 0.1.3, but RHEL 6 has only python-pyasn1-0.0.12a-1.el6.  python2-rsa is now impossible to install because it cannot resolve this dependency.


Version-Release number of selected component (if applicable):
python2-rsa-3.3-2.el6


How reproducible:
Always


Steps to Reproduce:
1. yum install python2-rsa


Actual results:
--> Processing Dependency: python-pyasn1 >= 0.1.3 for package: python2-rsa-3.3-2.el6.noarch
--> Finished Dependency Resolution
Error: Package: python2-rsa-3.3-2.el6.noarch (epel)
           Requires: python-pyasn1 >= 0.1.3
           Available: python-pyasn1-0.0.12a-1.el6.noarch (rhel-6-server-rpms)
               python-pyasn1 = 0.0.12a-1.el6


Additional info:
If python-rsa actually requires a version that recent to function then perhaps a new python-pyasn1v01 package is in order.
Comment 1 Anssi Johansson 2016-02-01 16:46:37 EST
Duplicate of bug 1303660.
Comment 2 Ian Wienand 2016-02-01 18:20:32 EST

*** This bug has been marked as a duplicate of bug 1303660 ***

Note You need to log in before you can comment on or make changes to this bug.