This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1303670 - Rebase tempest-liberty branch to latest upstream tag
Rebase tempest-liberty branch to latest upstream tag
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tempest (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity high
: ga
: 8.0 (Liberty)
Assigned To: Daniel Mellado
tkammer
https://github.com/redhat-openstack/t...
: Automation, AutomationBlocker, Rebase
Depends On: 1305140
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-01 10:53 EST by Daniel Mellado
Modified: 2016-04-07 17:27 EDT (History)
5 users (show)

See Also:
Fixed In Version: openstack-tempest-liberty-20160317.1.el7ost
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
: 1305140 (view as bug list)
Environment:
Last Closed: 2016-04-07 17:27:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Mellado 2016-02-01 10:53:45 EST
Description of problem:
The rpm version of tempest-liberty is more than 4 months old, so it'll have to be rebased to cover latest features and enhancements.


Version-Release number of selected component (if applicable):

Git-tag

https://github.com/redhat-openstack/tempest/tree/openstack-tempest-liberty-20160126

Actual results:

Get an updated tagged version for rpm build
Comment 2 Steve Linabery 2016-02-05 14:32:51 EST
Some of the upstream dependencies from requirements.txt are not met by our spec.

In particular, requirements.txt on the midstream tag has:
oslo.config>=3.2.0 # Apache-2.0
oslo.log>=1.14.0 # Apache-2.0
oslo.serialization>=1.10.0 # Apache-2.0
oslo.utils>=3.2.0 # Apache-2.0

And our spec has:
Requires:       python-oslo-config >= 2:2.4.0
Requires:       python-oslo-log >= 1.11.0
Requires:       python-oslo-serialization >= 1.9.0
Requires:       python-oslo-utils >= 2.5.0

However, I did a full tempest run against an OSP8 installation using the new build, and it worked. So the assumption is that the version requirements (many of which are post liberty freeze versions) were just global version bumps and our build is ok.
Comment 8 nlevinki 2016-04-06 03:57:57 EDT
rpm -qa | grep tempest
openstack-tempest-liberty-20160317.1.el7ost.noarch
Comment 9 errata-xmlrpc 2016-04-07 17:27:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.