Red Hat Bugzilla – Bug 1303670
Rebase tempest-liberty branch to latest upstream tag
Last modified: 2016-04-07 17:27:15 EDT
Description of problem:
The rpm version of tempest-liberty is more than 4 months old, so it'll have to be rebased to cover latest features and enhancements.
Version-Release number of selected component (if applicable):
Get an updated tagged version for rpm build
Some of the upstream dependencies from requirements.txt are not met by our spec.
In particular, requirements.txt on the midstream tag has:
oslo.config>=3.2.0 # Apache-2.0
oslo.log>=1.14.0 # Apache-2.0
oslo.serialization>=1.10.0 # Apache-2.0
oslo.utils>=3.2.0 # Apache-2.0
And our spec has:
Requires: python-oslo-config >= 2:2.4.0
Requires: python-oslo-log >= 1.11.0
Requires: python-oslo-serialization >= 1.9.0
Requires: python-oslo-utils >= 2.5.0
However, I did a full tempest run against an OSP8 installation using the new build, and it worked. So the assumption is that the version requirements (many of which are post liberty freeze versions) were just global version bumps and our build is ok.
rpm -qa | grep tempest
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory, and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.