Bug 1303770 - Document new options of multipath command that add machine-readable/parseable output
Document new options of multipath command that add machine-readable/parseable...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-DM_Multipath (Show other bugs)
6.8
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Steven J. Levine
ecs-bugs
: Documentation
Depends On: 1145442
Blocks: 1299651 1310185 1376206
  Show dependency treegraph
 
Reported: 2016-02-01 17:50 EST by Steven J. Levine
Modified: 2016-09-15 13:19 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1145442
: 1310185 1376206 (view as bug list)
Environment:
Last Closed: 2016-09-15 13:19:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Steven J. Levine 2016-02-02 11:44:18 EST
Ben:

It looks as though I don't document the "multipathd show" command at all in the current DM-Multipath manual. Do you think we should add a table similar to this one for multipath:

http://documentation-devel.engineering.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/DM_Multipath/multipath_options.html

If so, do you have suggestions for what we might include in that table?

Also:

For RHEL 7, we added a statement at the end of that table about using multipathd with wildcards -- which is odd because we don't otherwise talk about multipathd display commands, just multipath commands so I think I may have been confused when I added that. In any case, do we now add a similar sentence to the 6.8 version:

http://documentation-devel.engineering.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/DM_Multipath/multipath_options.html

Steven
Comment 3 Ben Marzinski 2016-02-12 14:23:41 EST
I don't know if we need to do anything like comprehensive documentation on the multipathd commands, but we should mention that there are a number of them, and they aren't just for troubleshooting. Most of the functionality of the multipath command also exists in multipathd commands. The document does point the reader to the help command, which is good. It would also be good to mention that you don't need to enter the interactive mode to issue these commands, simply running

# multipathd <command> <arguments>

will issue the command and print the results. We might want to call special attention to the format commands (and starting in RHEL-6.8 and RHEL-7.3, the raw format commands).

They are

list|show maps|multipaths format $format
list|show paths format $format
list|show maps|multipaths raw format $format
list|show paths raw format $format

The difference between the raw and the regular versions is that with the raw versions, no headers are printed, and the fields are not padded to appear in nice columns. Instead they print out exactly as specified in the format string.
This is helpful for scripting.

The wildcards that are used in the format string can be shown with the wildcard command.

Also, starting in RHEL-7.3 and RHEL-6.9 (not the upcoming RHEL6 release, the one after it), there will be two additional commands

list|show pathgroups format $format
list|show pathgroups raw format $format

To display pathgroup information.

Note You need to log in before you can comment on or make changes to this bug.