Bug 1303798 - "BuildRequires: python3-pyasn1 >= 0.1.3" causes yum update to fail on CentOS 6 AWS Marketplace AMI
"BuildRequires: python3-pyasn1 >= 0.1.3" causes yum update to fail on CentOS...
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: python-rsa (Show other bugs)
el6
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Yohan Graterol
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-01 20:53 EST by Glen K
Modified: 2016-02-03 21:28 EST (History)
5 users (show)

See Also:
Fixed In Version: python-rsa-3.3-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-03 21:28:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Glen K 2016-02-01 20:53:46 EST
Description of problem:
As of the release of python2-rsa-3.3-2, `yum update` no longer succeeds when EPEL is installed on a CentOS 6 HVM AWS AMI instance. This appears to be due to the addition of ">= 0.1.3" to the RPM's dependency on python-pyasn1 (previously there was no specific version required of python-pyasn1). See this commit: http://pkgs.fedoraproject.org/cgit/rpms/python-rsa.git/commit/?id=d8e0163c3f7629c666cbf820ac3c81bf061c8eb7

Version-Release number of selected component (if applicable): python2-rsa-3.3-2


How reproducible: Always


Steps to Reproduce:
1. Launch a CentOS 6 HVM AMI instance from AWS Marketplace: https://aws.amazon.com/marketplace/pp/B00NQAYLWO/ref=sp_mpg_product_title?ie=UTF8&sr=0-4
2. Log into the instance as centos user.
3. Install EPEL: `sudo yum install epel-release`
4. Perform yum update: `sudo yum -y update`

Actual results:

sudo yum -y update
...
--> Processing Dependency: python-rsa for package: python-boto-2.38.0-1.el6.noarch
---> Package selinux-policy.noarch 0:3.7.19-279.el6_7.6 will be updated
---> Package selinux-policy.noarch 0:3.7.19-279.el6_7.8 will be an update
---> Package selinux-policy-targeted.noarch 0:3.7.19-279.el6_7.6 will be updated
---> Package selinux-policy-targeted.noarch 0:3.7.19-279.el6_7.8 will be an update
---> Package tzdata.noarch 0:2015f-1.el6 will be updated
---> Package tzdata.noarch 0:2015g-2.el6 will be an update
---> Package udev.x86_64 0:147-2.63.el6 will be updated
---> Package udev.x86_64 0:147-2.63.el6_7.1 will be an update
--> Running transaction check
---> Package python2-rsa.noarch 0:3.3-2.el6 will be installed
--> Processing Dependency: python-pyasn1 >= 0.1.3 for package: python2-rsa-3.3-2.el6.noarch
--> Finished Dependency Resolution
Error: Package: python2-rsa-3.3-2.el6.noarch (epel)
           Requires: python-pyasn1 >= 0.1.3
           Available: python-pyasn1-0.0.12a-1.el6.noarch (base)
               python-pyasn1 = 0.0.12a-1.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 1 Anssi Johansson 2016-02-02 01:40:59 EST
Duplicate of bug 1303660.
Comment 2 Fedora Update System 2016-02-02 07:15:44 EST
python-rsa-3.3-3.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-16806dbf19
Comment 3 Fedora Update System 2016-02-02 19:21:29 EST
python-rsa-3.3-3.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-16806dbf19
Comment 4 Fedora Update System 2016-02-03 21:28:07 EST
python-rsa-3.3-3.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.