Bug 1303809 - provide QEMU guest agent command for setting root/administrator account password - window guests
Summary: provide QEMU guest agent command for setting root/administrator account passw...
Keywords:
Status: CLOSED DUPLICATE of bug 1313887
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Gal Hammer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 1303808 (view as bug list)
Depends On: 1303808
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-02-02 03:41 UTC by weliao
Modified: 2019-10-10 11:04 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of: 1303808
Environment:
Last Closed: 2016-09-05 07:45:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2609 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2016-11-03 15:27:12 UTC

Description weliao 2016-02-02 03:41:26 UTC
+++ This bug was initially created as a clone of Bug #1303808 +++

Description of problem:
According to Bug 1174176, need provide QEMU guest agent command for setting root/administrator account password supported RHEL *and* Windows versions.

Version-Release number of selected component (if applicable):
Host:
3.10.0-309.el7.x86_64
qemu-kvm-rhev-2.3.0-23.el7.x86_64
Guest:
win10
qemu-ga-win-7.2.1-1

How reproducible:
100%

Steps to Reproduce:
1.Launch win10 guest and install qemu-ga-x86.msi in guest,seems windows guest didn't support set password by qemu-guest-agent.

# nc -U /tmp/qga.sock
{"execute":"guest-info"}
{"return": {"version": "0.12.1", "supported_commands": [{"enabled": true, "name": "guest-set-vcpus"}, {"enabled": true, "name": "guest-get-vcpus"}, {"enabled": true, "name": "guest-network-get-interfaces"}, {"enabled": true, "name": "guest-suspend-hybrid"}, {"enabled": true, "name": "guest-suspend-ram"}, {"enabled": true, "name": "guest-suspend-disk"}, {"enabled": true, "name": "guest-fstrim"}, {"enabled": true, "name": "guest-fsfreeze-thaw"}, {"enabled": true, "name": "guest-fsfreeze-freeze"}, {"enabled": true, "name": "guest-fsfreeze-status"}, {"enabled": true, "name": "guest-file-flush"}, {"enabled": true, "name": "guest-file-seek"}, {"enabled": true, "name": "guest-file-write"}, {"enabled": true, "name": "guest-file-read"}, {"enabled": true, "name": "guest-file-close"}, {"enabled": true, "name": "guest-file-open"}, {"enabled": true, "name": "guest-shutdown"}, {"enabled": true, "name": "guest-info"}, {"enabled": true, "name": "guest-set-time"}, {"enabled": true, "name": "guest-get-time"}, {"enabled": true, "name": "guest-ping"}, {"enabled": true, "name": "guest-sync"}, {"enabled": true, "name": "guest-sync-delimited"}]}}

{"execute":"guest-set-user-password","arguments":{"crypted":false,"username":"root","password":"cmVkaGF0"}}
{"error": {"desc": "The command guest-set-user-password has not been found"}}
2.
3.

Actual results:
Do not supported set root/administrator account password

Expected results:
Can set root/administrator account password

Additional info:
command:
/usr/libexec/qemu-kvm -name rhel7.2 -M pc-i440fx-rhel7.2.0,accel=kvm,usb=off,vmport=off -cpu SandyBridge -m 4096 -realtime mlock=off -smp 2, -drive file=/home/win10_32.qcow2,if=none,id=drive-virtio-disk0,format=qcow2 -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x7,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -netdev tap,id=hostnet0,vhost=on,script=/etc/ovs-ifup,downscript=/etc/ovs-ifdown  -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:55:00:77:89:4d,bus=pci.0,addr=0x3 \
-device qxl-vga,id=video0,ram_size=67108864,vram_size=67108864,vgamem_mb=16,bus=pci.0,addr=0x2 -spice port=6600,disable-ticketing, \
-monitor stdio \
-cdrom /usr/share/virtio-win/virtio-win.iso \
-device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x5 \
-chardev socket,path=/tmp/qga.sock,server,nowait,id=qga0 \
-device virtserialport,bus=virtio-serial0.0,chardev=qga0,name=org.qemu.guest_agent.0

Comment 2 Ademar Reis 2016-02-03 13:01:30 UTC
*** Bug 1303808 has been marked as a duplicate of this bug. ***

Comment 3 Gal Hammer 2016-03-15 15:36:20 UTC
Back ported the command implementation from upstream.

Comment 4 Mike McCune 2016-03-28 22:39:30 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 5 Gal Hammer 2016-07-05 14:16:41 UTC
Yan? Do we have a qga-win build which include this fix? Thanks.

Comment 6 Yan Vugenfirer 2016-07-12 06:57:22 UTC
(In reply to Gal Hammer from comment #5)
> Yan? Do we have a qga-win build which include this fix? Thanks.

Yes, same build as for BZ#1303906 - qemu-ga-win-7.3.2-1


Note You need to log in before you can comment on or make changes to this bug.