Bug 1313887 - [RFE] provide QEMU guest agent command for setting root account password (Windows guest) [rhel-7.3]
Summary: [RFE] provide QEMU guest agent command for setting root account password (Win...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Gal Hammer
QA Contact: Xueqiang Wei
URL:
Whiteboard:
: 1303809 (view as bug list)
Depends On: 1174176 1174181
Blocks: 1303906
TreeView+ depends on / blocked
 
Reported: 2016-03-02 14:34 UTC by Amnon Ilan
Modified: 2016-11-04 08:52 UTC (History)
24 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
NO_DOCS
Clone Of: 1174181
Environment:
Last Closed: 2016-11-04 08:52:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2609 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2016-11-03 15:27:12 UTC

Comment 2 Amnon Ilan 2016-03-02 14:40:06 UTC

*** This bug has been marked as a duplicate of bug 1303906 ***

Comment 8 Miroslav Rezanina 2016-07-18 06:12:11 UTC
Currently, RHEL qemu-guest-agent is not related to win-ga component. There's no possibility to fix it now. This issue is handle with BZ 1303906.

Comment 18 Amnon Ilan 2016-09-05 07:45:49 UTC
*** Bug 1303809 has been marked as a duplicate of this bug. ***

Comment 19 Xueqiang Wei 2016-09-06 10:01:33 UTC
for crypted is false, the test is passed.
for crypted is true, the test is failed, return message "Unsupported".

the details as below:
host: kernel-3.10.0-500.el7.x86_64
      qemu-kvm-rhev-2.6.0-22.el7
guest: win10
       qemu-ga-win-7.3.2-1

some logs:

set password: redhat

{"execute":"guest-set-user-password","arguments":{"crypted":false,"username":"Administrator","password":"cmVkaGF0"}}
{"return": {}}

then reboot guest, login using the new password successfully


{"execute":"guest-set-user-password","arguments":{"crypted":true,"username":"Administrator","password":"SExHVVNmUTJoRjVXZw=="}}
{"error": {"desc": "{ 'class': 'Unsupported', 'data': {} }"}}

Comment 20 Marc-Andre Lureau 2016-09-06 11:30:07 UTC
windows doesn't support crypt()d passwords, as indicated by the error message.

Comment 21 Xueqiang Wei 2016-09-07 02:45:32 UTC
According to Comment 19 and Comment 20, change the status to VERIFIED.

Comment 23 errata-xmlrpc 2016-11-04 08:52:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2609.html


Note You need to log in before you can comment on or make changes to this bug.