Bug 1303828 - [USS]: If .snaps already exists, ls -la lists it even after enabling USS
Summary: [USS]: If .snaps already exists, ls -la lists it even after enabling USS
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Manikandan
QA Contact:
URL:
Whiteboard: USS
Depends On: 1159283 1170502 1303593 1303595
Blocks: 1153907 1306163
TreeView+ depends on / blocked
 
Reported: 2016-02-02 07:05 UTC by Vijaikumar Mallikarjuna
Modified: 2016-06-16 13:56 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1303593
: 1306163 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:56:34 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-02-02 07:06:26 UTC
REVIEW: http://review.gluster.org/13330 (USS: pre-existing .snaps should not be listed with 'ls -a' with USS enabled) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 2 Vijay Bellur 2016-02-09 07:53:02 UTC
REVIEW: http://review.gluster.org/13330 (USS: pre-existing .snaps should not be listed with 'ls -a' with USS enabled) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 3 Vijay Bellur 2016-02-10 01:04:43 UTC
REVIEW: http://review.gluster.org/13330 (USS: pre-existing .snaps should not be listed with 'ls -a' with USS enabled) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 4 Vijay Bellur 2016-02-12 06:29:56 UTC
REVIEW: http://review.gluster.org/13330 (USS: pre-existing .snaps should not be listed with 'ls -a' with USS enabled) posted (#4) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 5 Vijay Bellur 2016-02-15 08:20:35 UTC
COMMIT: http://review.gluster.org/13330 committed in master by Rajesh Joseph (rjoseph@redhat.com) 
------
commit 954f2901345f42177033418112c052ed0795b295
Author: vmallika <vmallika@redhat.com>
Date:   Tue Feb 2 12:30:16 2016 +0530

    USS: pre-existing .snaps should not be listed with 'ls -a' with USS enabled
    
    If there is a .snaps directory pre-exists and when USS is enabled,
    it should not be listed with 'ls -a'
    
    Change-Id: I1c43e2decc0bbbd3213b190b675e3a32d04b22d3
    BUG: 1303828
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/13330
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>

Comment 8 Niels de Vos 2016-06-16 13:56:34 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.