Bug 1306163 - [USS]: If .snaps already exists, ls -la lists it even after enabling USS
Summary: [USS]: If .snaps already exists, ls -la lists it even after enabling USS
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: 3.7.7
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Vijaikumar Mallikarjuna
QA Contact:
URL:
Whiteboard: USS
Depends On: 1159283 1170502 1303593 1303595 1303828
Blocks: 1153907
TreeView+ depends on / blocked
 
Reported: 2016-02-10 08:23 UTC by Vijaikumar Mallikarjuna
Modified: 2016-04-19 07:25 UTC (History)
8 users (show)

Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Clone Of: 1303828
Environment:
Last Closed: 2016-04-19 07:25:16 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-02-10 08:24:34 UTC
REVIEW: http://review.gluster.org/13419 (USS: pre-existing .snaps should not be listed with 'ls -a' with USS enabled) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 2 Vijay Bellur 2016-02-12 06:28:34 UTC
REVIEW: http://review.gluster.org/13419 (USS: pre-existing .snaps should not be listed with 'ls -a' with USS enabled) posted (#2) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 3 Vijay Bellur 2016-02-15 08:27:17 UTC
COMMIT: http://review.gluster.org/13419 committed in release-3.7 by Rajesh Joseph (rjoseph@redhat.com) 
------
commit b47f741b5f42d2e7d994cd06e1c1c679fd9e9535
Author: vmallika <vmallika@redhat.com>
Date:   Wed Feb 10 13:53:12 2016 +0530

    USS: pre-existing .snaps should not be listed with 'ls -a' with USS
    enabled
    
    This is a backport of http://review.gluster.org/#/c/13330/
    
    If there is a .snaps directory pre-exists and when USS is enabled,
    it should not be listed with 'ls -a'
    
    > Change-Id: I1c43e2decc0bbbd3213b190b675e3a32d04b22d3
    > BUG: 1303828
    > Signed-off-by: vmallika <vmallika@redhat.com>
    
    Change-Id: I76c632239b45f7eb7296cbfe3b73bc68e5bd1655
    BUG: 1306163
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/13419
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>

Comment 4 Kaushal 2016-04-19 07:25:16 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.