Bug 1303928 - [RFE] Calamari should emit events when Pool is added or deleted.
[RFE] Calamari should emit events when Pool is added or deleted.
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Calamari (Show other bugs)
1.3.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 2.0
Assigned To: Gregory Meno
Harish NV Rao
:
Depends On:
Blocks: 1291304
  Show dependency treegraph
 
Reported: 2016-02-02 07:42 EST by Darshan
Modified: 2017-02-17 14:44 EST (History)
7 users (show)

See Also:
Fixed In Version: RHEL: calamari-server-1.4.0-0.6.rc9.el7cp Ubuntu: calamari-server_1.4.0~rc9-2redhat1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-23 15:29:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2934131 None None None 2017-02-17 14:44 EST

  None (edit)
Description Darshan 2016-02-02 07:42:05 EST
Description of problem:
calamari should emit events when a new pool is added or an existing pool is deleted, with all relevant info. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 3 Sharmilla Abhilash 2016-04-15 03:55:14 EDT
The Target Release should be 2.0 for this one ?
Comment 7 Darshan 2016-06-10 08:07:49 EDT
The Fix works as Expected. I tried creating new pools on a ceph cluster and subsequently deleted them. Calamari successfully pushed events into salt bus reporting the addition and deletion of the pool. These events were also available at salt-master.

Hence moving it to Verified state.
Comment 8 Gregory Meno 2016-06-20 14:05:01 EDT
This is something I would like to omit from the release notes. Any calamari emits events should be left out. This specific functionality is for USM and will be depreciated very soon.
Comment 11 errata-xmlrpc 2016-08-23 15:29:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1755

Note You need to log in before you can comment on or make changes to this bug.