Bug 1303933 - [RFE] Calamari should emit events for CRUSH updates.
[RFE] Calamari should emit events for CRUSH updates.
Status: CLOSED WONTFIX
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Calamari (Show other bugs)
1.3.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 2.3
Assigned To: Gregory Meno
ceph-qe-bugs
: FutureFeature
Depends On:
Blocks: 1291304
  Show dependency treegraph
 
Reported: 2016-02-02 07:55 EST by Darshan
Modified: 2017-03-31 11:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-31 11:49:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darshan 2016-02-02 07:55:53 EST
Description of problem:
calamari should emit events whenever there is changes to crush map, with all relevant info. This is needed because, if admin does out of band management and updates the crush map, we need to get an event, so that RHS-contorller  remains in sync.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Darshan 2016-02-09 00:30:48 EST
To be specific when crush is updated, crush bucket creation, crush rule add/remove/update.

Note You need to log in before you can comment on or make changes to this bug.