Bug 1303973 - ovirt-system-tests: ovirt engine installation fails because of wrong answer in the answer file
ovirt-system-tests: ovirt engine installation fails because of wrong answer i...
Status: CLOSED UPSTREAM
Product: ovirt-engine
Classification: oVirt
Component: Setup.Core (Show other bugs)
3.6.3
x86_64 Linux
unspecified Severity high (vote)
: ---
: ---
Assigned To: Yaniv Kaul
Pavel Stehlik
: Automation, CodeChange
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-02 10:05 EST by Yaniv Kaul
Modified: 2017-05-11 05:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1302045
Environment:
Last Closed: 2016-03-24 14:18:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: External
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 53518 None None None 2016-02-15 06:40 EST

  None (edit)
Description Yaniv Kaul 2016-02-02 10:05:14 EST
+++ This bug was initially created as a clone of Bug #1302045 +++

Description of problem:
In basic_suite_3.6/engine-answer-file.conf , the value
OSETUP_RPMDISTRO/enableUpgrade=none:None
Should be:
OSETUP_RPMDISTRO/enableUpgrade=bool:False

Version-Release number of selected component (if applicable):
5a2c9e79d8bf15581242075c5eb53b9b34f5ae96

How reproducible:
Always - though I'm not sure how it worked so far!

--- Additional comment from Red Hat Bugzilla Rules Engine on 2016-01-26 18:12:16 IST ---

Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.

--- Additional comment from Red Hat Bugzilla Rules Engine on 2016-01-26 18:12:16 IST ---

Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

--- Additional comment from Red Hat Bugzilla Rules Engine on 2016-01-26 18:13:04 IST ---

Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.

--- Additional comment from Red Hat Bugzilla Rules Engine on 2016-01-26 18:13:04 IST ---

Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

--- Additional comment from Red Hat Bugzilla Rules Engine on 2016-01-26 18:13:26 IST ---

Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 1 Yaniv Kaul 2016-02-02 10:07:00 EST
The real issue is that we did not test the success of the installation.
Proposed patch to the engine installation test:
diff --git a/basic_suite_3.6/test-scenarios/001_initialize_engine.py b/basic_suite_3.6/test-scenarios/001_initialize_engine.py
index 3347a1e..bc950ce 100644
--- a/basic_suite_3.6/test-scenarios/001_initialize_engine.py
+++ b/basic_suite_3.6/test-scenarios/001_initialize_engine.py
@@ -35,9 +35,16 @@ def test_initialize_engine(prefix):
         '/tmp/answer-file',
     )
 
-    engine.ssh(
+    result = engine.ssh(
         [
             'engine-setup',
             '--config-append=/tmp/answer-file',
         ],
     )
+
+    testlib.assert_true_within_short(
+        lambda: False if result != 0 else True
+    )
+    testlib.assert_true_within_long(
+        lambda: engine.service('ovirt-engine').alive()
+    )


David - where should I send this patch to?
Comment 2 Yedidyah Bar David 2016-02-02 10:16:08 EST
(In reply to Yaniv Kaul from comment #0)
> How reproducible:
> Always - though I'm not sure how it worked so far!

A wild guess: Because of bug 1301902
Comment 3 Yaniv Kaul 2016-02-03 12:50:02 EST
The above code in comment 1 is a bit flawed - should check for result.code value.
Comment 4 David Caro 2016-02-22 07:15:18 EST
Replied by email

Note You need to log in before you can comment on or make changes to this bug.