Bug 1303995 - SMB: SMB crashes with AIO enabled on reads + vers=3.0
SMB: SMB crashes with AIO enabled on reads + vers=3.0
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: gluster-smb (Show other bugs)
mainline
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: rjoseph
: ZStream
Depends On: 1302901 1311146
Blocks: 1311578
  Show dependency treegraph
 
Reported: 2016-02-02 11:21 EST by rjoseph
Modified: 2016-06-16 09:56 EDT (History)
13 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1302901
: 1311578 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:56:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-02-02 11:32:33 EST
REVIEW: http://review.gluster.org/13340 (libgfapi: fd close is not correctly handled for async fop) posted (#1) for review on master by Rajesh Joseph (rjoseph@redhat.com)
Comment 2 Vijay Bellur 2016-02-03 07:07:58 EST
REVIEW: http://review.gluster.org/13340 (libgfapi: fd close is not correctly handled for async fop) posted (#2) for review on master by Rajesh Joseph (rjoseph@redhat.com)
Comment 3 Vijay Bellur 2016-02-03 10:31:30 EST
REVIEW: http://review.gluster.org/13340 (libgfapi: glfd close is not correctly handled for async fop) posted (#3) for review on master by Rajesh Joseph (rjoseph@redhat.com)
Comment 4 Vijay Bellur 2016-02-03 10:43:12 EST
REVIEW: http://review.gluster.org/13340 (libgfapi: glfd close is not correctly handled for async fop) posted (#4) for review on master by Rajesh Joseph (rjoseph@redhat.com)
Comment 5 Vijay Bellur 2016-02-04 02:01:29 EST
REVIEW: http://review.gluster.org/13340 (libgfapi: glfd close is not correctly handled for async fop) posted (#5) for review on master by Rajesh Joseph (rjoseph@redhat.com)
Comment 6 Vijay Bellur 2016-02-04 05:15:31 EST
REVIEW: http://review.gluster.org/13340 (libgfapi: glfd close is not correctly handled for async fop) posted (#6) for review on master by Rajesh Joseph (rjoseph@redhat.com)
Comment 7 Vijay Bellur 2016-02-04 11:05:18 EST
REVIEW: http://review.gluster.org/13340 (libgfapi: glfd close is not correctly handled for async fop) posted (#7) for review on master by Rajesh Joseph (rjoseph@redhat.com)
Comment 8 Vijay Bellur 2016-02-04 12:46:36 EST
REVIEW: http://review.gluster.org/13340 (libgfapi: glfd close is not correctly handled for async fop) posted (#8) for review on master by Rajesh Joseph (rjoseph@redhat.com)
Comment 9 Vijay Bellur 2016-02-04 13:28:36 EST
REVIEW: http://review.gluster.org/13340 (libgfapi: glfd close is not correctly handled for async fop) posted (#9) for review on master by Rajesh Joseph (rjoseph@redhat.com)
Comment 10 Vijay Bellur 2016-02-04 23:21:23 EST
REVIEW: http://review.gluster.org/13340 (libgfapi: glfd close is not correctly handled for async fop) posted (#10) for review on master by Rajesh Joseph (rjoseph@redhat.com)
Comment 11 Vijay Bellur 2016-02-11 00:46:33 EST
COMMIT: http://review.gluster.org/13340 committed in master by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit 88d772c05c45c467bfccebfc51f6a0e0ea9ca287
Author: Rajesh Joseph <rjoseph@redhat.com>
Date:   Tue Feb 2 04:22:04 2016 +0530

    libgfapi: glfd close is not correctly handled for async fop
    
    There is chance that before the async fop is complete client can send
    a close. libgfapi destroys glfd on close. Therefore it can lead to
    crash or unexpected behaviour when the pening fop reaches libgfapi
    layer. Currently we don't provide any api to cancel these outstanding
    fops neither we check if the glfd is already closed or not.
    
    Therefore as a fix provided refcount for glfd. Each fop (sync or async)
    will take a ref and once the fop is complete it will unref the refcount.
    We should not call the registered callback function if glfd is already
    closed. To achieve this we maintain state of glfd so that we can safely
    take a call if the fd is closed or not.
    
    Change-Id: Ibe71b2225312db3f1be66b244fcf8826c70c357d
    BUG: 1303995
    Signed-off-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-on: http://review.gluster.org/13340
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Comment 12 Niels de Vos 2016-02-28 04:41:05 EST
Bug 1311146 reports a regression that was introduced with this change.
Comment 13 rjoseph 2016-04-26 00:23:36 EDT
http://review.gluster.org/13666 fixes regression reported by Bug 1311146.
Comment 14 Niels de Vos 2016-06-16 09:56:34 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.