Bug 1311578 - SMB: SMB crashes with AIO enabled on reads + vers=3.0
SMB: SMB crashes with AIO enabled on reads + vers=3.0
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: gluster-smb (Show other bugs)
3.7.9
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: bugs@gluster.org
: ZStream
Depends On: 1302901 1303995
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-24 09:01 EST by rjoseph
Modified: 2016-04-19 02:58 EDT (History)
12 users (show)

See Also:
Fixed In Version: glusterfs-3.7.10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1303995
Environment:
Last Closed: 2016-04-19 02:58:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-02-24 09:10:16 EST
REVIEW: http://review.gluster.org/13512 (libgfapi: glfd close is not correctly handled for async fop) posted (#1) for review on release-3.7 by Rajesh Joseph (rjoseph@redhat.com)
Comment 2 Mike McCune 2016-03-28 18:23:05 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 3 Vijay Bellur 2016-03-29 06:00:17 EDT
REVIEW: http://review.gluster.org/13512 (libgfapi: glfd close is not correctly handled for async fop) posted (#2) for review on release-3.7 by Rajesh Joseph (rjoseph@redhat.com)
Comment 4 Vijay Bellur 2016-03-30 10:08:40 EDT
REVIEW: http://review.gluster.org/13512 (libgfapi: glfd close is not correctly handled for async fop) posted (#3) for review on release-3.7 by Niels de Vos (ndevos@redhat.com)
Comment 5 Vijay Bellur 2016-03-30 10:23:30 EDT
COMMIT: http://review.gluster.org/13512 committed in release-3.7 by Niels de Vos (ndevos@redhat.com) 
------
commit e761050fb44b28c0641dd87f5fbc9d1511bed92b
Author: Rajesh Joseph <rjoseph@redhat.com>
Date:   Tue Feb 2 04:22:04 2016 +0530

    libgfapi: glfd close is not correctly handled for async fop
    
    There is chance that before the async fop is complete client can send
    a close. libgfapi destroys glfd on close. Therefore it can lead to
    crash or unexpected behaviour when the pening fop reaches libgfapi
    layer. Currently we don't provide any api to cancel these outstanding
    fops neither we check if the glfd is already closed or not.
    
    Therefore as a fix provided refcount for glfd. Each fop (sync or async)
    will take a ref and once the fop is complete it will unref the refcount.
    We should not call the registered callback function if glfd is already
    closed. To achieve this we maintain state of glfd so that we can safely
    take a call if the fd is closed or not.
    
    Backport of commit 88d772c05c45c467bfccebfc51f6a0e0ea9ca287:
    > Change-Id: Ibe71b2225312db3f1be66b244fcf8826c70c357d
    > BUG: 1303995
    > Signed-off-by: Rajesh Joseph <rjoseph@redhat.com>
    > Reviewed-on: http://review.gluster.org/13340
    > Smoke: Gluster Build System <jenkins@build.gluster.com>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    
    Change-Id: I1e01690ea72f34c12465eb084d7a1aa9de0d7b83
    BUG: 1311578
    Signed-off-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-on: http://review.gluster.org/13512
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
Comment 6 Kaushal 2016-04-19 02:58:43 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.10, please open a new bug report.

glusterfs-3.7.10 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-April/026164.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.