Bug 1303997 - Openstack cloud instances do not show both IPv4 and IPv6 addresses when attached to dual stack network
Openstack cloud instances do not show both IPv4 and IPv6 addresses when attac...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Ladislav Smola
Ola Pavlenko
openstack
: ZStream
Depends On:
Blocks: 1327605
  Show dependency treegraph
 
Reported: 2016-02-02 11:23 EST by Marius Cornea
Modified: 2017-08-29 23:46 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.6.0.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1327605 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:35:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dual stack ip screenshow (97.03 KB, image/png)
2016-06-14 07:32 EDT, Marius Cornea
no flags Details

  None (edit)
Description Marius Cornea 2016-02-02 11:23:04 EST
Description of problem:
Openstack cloud instances do not show both IPv4 and IPv6 addresses when attached to dual stack network. 

Version-Release number of selected component (if applicable):
5.5.2.4.20160127105142_395c086

How reproducible:
100%

Steps to Reproduce:
1. Add Openstack cloud provider that has instances connected to dual stack networks with both IPv4 and IPv6 address
2. Go to Cloud -> Instance
3. Click on an instance
4. Check IP address 

Actual results:
IP Address	10.0.0.5

How it shows in nova list:
vm01 | ACTIVE | -          | Running     | provider-1000=10.0.0.5, 2001:db1::f816:3eff:fe69:c58f 

Expected results:
IP Address	10.0.0.5, 2001:db1::f816:3eff:fe69:c58f
Comment 2 Shveta 2016-02-02 19:13:52 EST
Assigning to add test case
Comment 3 Ronnie Rasouli 2016-04-14 10:23:54 EDT
Verification failed. 

The IP field in CFME 5.5.3.2 showing only ipv6 address

IP Address 	2001:db1::f816:3eff:fea3:4105 

In openstack
[stack@undercloud ~]$ nova list
+--------------------------------------+---------+--------+------------+-------------+-------------------------------------------------------+
| ID                                   | Name    | Status | Task State | Power State | Networks                                              |
+--------------------------------------+---------+--------+------------+-------------+-------------------------------------------------------+
| 9aaba28e-54ab-4cbc-a21b-280d44c31d82 | my_inst | ACTIVE | -          | Running     | provider-1000=2001:db1::f816:3eff:fea3:4105, 10.0.0.5 |
+--------------------------------------+---------+--------+------------+-------------+-------------------------------------------------------+
Comment 6 CFME Bot 2016-05-09 13:50:48 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/1d8ec2cbe94d92066216b9b5563c59017f018fcc

commit 1d8ec2cbe94d92066216b9b5563c59017f018fcc
Author:     Ladislav Smola <lsmola@redhat.com>
AuthorDate: Wed May 4 14:55:54 2016 +0200
Commit:     Ladislav Smola <lsmola@redhat.com>
CommitDate: Fri May 6 14:45:14 2016 +0200

    For Cloud VMs show IPs and MACs based on network_ports
    
    For Cloud VMs show IPs and MACs based on network_ports. Which is
    also fixing showing ip's when VM have multiple ports. And for
    ipv6, showing all IPs, even when multiple IPs are associated to
    one port.
    
    For now, only Google Provider is not supporting this, until it will
    be rewritten to use a NetworkManager.
    
    Fixes BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1303997
    https://bugzilla.redhat.com/show_bug.cgi?id=1316026

 app/models/manageiq/providers/cloud_manager/vm.rb        | 11 +++++++++++
 app/models/manageiq/providers/google/cloud_manager/vm.rb | 11 +++++++++++
 app/models/network_port.rb                               | 16 ++++++++++++++++
 3 files changed, 38 insertions(+)
Comment 10 Marius Cornea 2016-06-14 07:32 EDT
Created attachment 1167840 [details]
dual stack ip screenshow

vm01                                                  | ACTIVE | -          | Running     | provider-1000=2001:db1::f816:3eff:fe40:da41, 10.0.0.3
Comment 12 errata-xmlrpc 2016-06-29 11:35:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.