Bug 1316026 - Unable to list multiple IP Addresses of an instance running on OpenStack environment.
Unable to list multiple IP Addresses of an instance running on OpenStack envi...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Ladislav Smola
Ola Pavlenko
openstack
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-09 04:46 EST by Nikhil Gupta
Modified: 2017-08-29 23:49 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.6.0.6
Doc Type: Bug Fix
Doc Text:
Previously, CloudForms did not list multiple IP addresses for OpenStack cloud instances. The CloudForms code has been rewritten so that all cloud instances show IP and MAC addresses based on the network_ports parameter, and now CloudForms correctly displays multiple IP addresses on a cloud instance.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:41:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2481471 None None None 2016-08-02 03:44 EDT

  None (edit)
Description Nikhil Gupta 2016-03-09 04:46:12 EST
Description of problem:
Unable to list multiple IP Addresses of a virtual machine in Openstack environment.

Virtual machine in OpenStack environment has got two NIC's associated of same network and different subnets. When we try to list details of this virtual machine via CFME REST API, it lists only one IP Address.
Even from CFME console , it shows only one IP Address associated with that VM.


Version-Release number of selected component (if applicable):
5.5.0.13.20151201120956_653c0d4


How reproducible:
Always

Steps to Reproduce:
1. Launce an instance with two nics on OpenStack environment
2. Then refresh OpenStack provider from CloudForms UI.
3. New instance will be discovered.

Actual results:
It is showing only one IP address on CFME UI.

Expected results:
Ideally, it should display all the IP addresses of VM associated with it.


Additional info:
Also we have checked it with the GET API call and it is showing only one IP:
/api/vms/99000000001165?expand=resources&attributes=name,power_state,ipaddresses,location,state_changed_on,previous_state

{
   "href": "https://<cfme>/api/vms/99000000001165",
   "id": 99000000001165,
   "name": "testvm-image",
   "power_state": "on",
   "location": "unknown",
   "state_changed_on": "2016-03-09T08:46:54Z",
   "ipaddresses": ["192.168.99.13"]
}
Comment 2 Ladislav Smola 2016-05-03 11:35:05 EDT
this BZ should be fixed by fixing https://bugzilla.redhat.com/show_bug.cgi?id=1303997
Comment 4 CFME Bot 2016-05-09 13:50:53 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/1d8ec2cbe94d92066216b9b5563c59017f018fcc

commit 1d8ec2cbe94d92066216b9b5563c59017f018fcc
Author:     Ladislav Smola <lsmola@redhat.com>
AuthorDate: Wed May 4 14:55:54 2016 +0200
Commit:     Ladislav Smola <lsmola@redhat.com>
CommitDate: Fri May 6 14:45:14 2016 +0200

    For Cloud VMs show IPs and MACs based on network_ports
    
    For Cloud VMs show IPs and MACs based on network_ports. Which is
    also fixing showing ip's when VM have multiple ports. And for
    ipv6, showing all IPs, even when multiple IPs are associated to
    one port.
    
    For now, only Google Provider is not supporting this, until it will
    be rewritten to use a NetworkManager.
    
    Fixes BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1303997
    https://bugzilla.redhat.com/show_bug.cgi?id=1316026

 app/models/manageiq/providers/cloud_manager/vm.rb        | 11 +++++++++++
 app/models/manageiq/providers/google/cloud_manager/vm.rb | 11 +++++++++++
 app/models/network_port.rb                               | 16 ++++++++++++++++
 3 files changed, 38 insertions(+)
Comment 7 Udi 2016-05-31 13:50:23 EDT
Verified in: 5.6.0.8-rc1-nightly.20160527091122_ced67ee
Comment 9 errata-xmlrpc 2016-06-29 11:41:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.