Bug 1304003 - Error while executing a report
Error while executing a report
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting (Show other bugs)
5.4.0
Unspecified Unspecified
unspecified Severity high
: GA
: 5.5.3
Assigned To: Joe Rafaniello
Alex Newman
: ZStream
Depends On: 1303074 1304006
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-02 11:33 EST by John Prause
Modified: 2017-08-29 21:35 EDT (History)
10 users (show)

See Also:
Fixed In Version: 5.5.3.2
Doc Type: Bug Fix
Doc Text:
Previously, attempting to queue a report created to list all VMs with thin provisioned disk, threw an error. This was caused because has_many through association was breaking the reporting. This patch fixes has_many through association that broke the reporting and the issue is now resolved.
Story Points: ---
Clone Of: 1303074
Environment:
Last Closed: 2016-04-13 14:42:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2145821 None None None 2016-02-02 11:33 EST

  None (edit)
Comment 3 Joe Rafaniello 2016-03-01 15:51:42 EST
See https://bugzilla.redhat.com/show_bug.cgi?id=1303074#c11 for details on how to fix the recreation steps to create the desired report.
Comment 4 CFME Bot 2016-03-01 17:11:03 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=8b44c0551bcf2174a2d76857b1ac3cf12f4040a4

commit 8b44c0551bcf2174a2d76857b1ac3cf12f4040a4
Merge: cf17bb3 c719e03
Author:     Gregg Tanzillo <gtanzill@redhat.com>
AuthorDate: Tue Mar 1 16:39:08 2016 -0500
Commit:     Gregg Tanzillo <gtanzill@redhat.com>
CommitDate: Tue Mar 1 16:39:08 2016 -0500

    Merge branch '55z_1303074' into '5.5.z'
    
    Fix has_many through association breaking reporting
    
    Backports of the following PRs with conflicts(rspec version changes) in the tests fixed:
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1304003
    
    https://github.com/ManageIQ/manageiq/pull/6650
    
    https://github.com/ManageIQ/manageiq/pull/6690
    
    https://github.com/ManageIQ/manageiq/pull/6903
    
    See merge request !828

 app/models/vm_or_template.rb       |  2 +-
 spec/models/miq_report_spec.rb     | 57 ++++++++++++++++++++++++++++++++++++--
 spec/models/vm_or_template_spec.rb | 26 +++++++++++++++++
 3 files changed, 81 insertions(+), 4 deletions(-)
Comment 11 errata-xmlrpc 2016-04-13 14:42:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0616

Note You need to log in before you can comment on or make changes to this bug.