Bug 1304006 - Error while executing a report
Error while executing a report
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting (Show other bugs)
5.4.0
Unspecified Unspecified
high Severity high
: GA
: 5.4.5
Assigned To: Joe Rafaniello
Aziza Karol
report:error
: ZStream
Depends On: 1303074
Blocks: 1304003
  Show dependency treegraph
 
Reported: 2016-02-02 11:36 EST by John Prause
Modified: 2017-08-29 21:23 EDT (History)
11 users (show)

See Also:
Fixed In Version: 5.4.5.2
Doc Type: Bug Fix
Doc Text:
Previously, attempting to queue a report created to list all VMs with thin provisioned disk, threw an error. This was caused because has_many through association was breaking the reporting. This patch fixes has_many through association that broke the reporting and the issue is now resolved.
Story Points: ---
Clone Of: 1303074
Environment:
Last Closed: 2016-03-29 10:17:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2145821 None None None 2016-02-02 11:36 EST

  None (edit)
Comment 3 Joe Rafaniello 2016-03-01 15:51:36 EST
See https://bugzilla.redhat.com/show_bug.cgi?id=1303074#c11 for details on how to fix the recreation steps to create the desired report.
Comment 4 CFME Bot 2016-03-01 16:31:57 EST
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=53b2467b2eade52b6b9c5a947361cd9450f48338

commit 53b2467b2eade52b6b9c5a947361cd9450f48338
Merge: fae2ba5 578ebf2
Author:     Gregg Tanzillo <gtanzill@redhat.com>
AuthorDate: Tue Mar 1 16:30:30 2016 -0500
Commit:     Gregg Tanzillo <gtanzill@redhat.com>
CommitDate: Tue Mar 1 16:30:30 2016 -0500

    Merge branch '54z_1303074' into '5.4.z'
    
    Fix has_many through association breaking reporting
    
    Backports of the following PRs with conflicts(rspec version changes) in the tests fixed:
    https://bugzilla.redhat.com/show_bug.cgi?id=1304006
    
    https://github.com/ManageIQ/manageiq/pull/6650
    
    https://github.com/ManageIQ/manageiq/pull/6690
    
    https://github.com/ManageIQ/manageiq/pull/6903
    
    See merge request !829

 vmdb/app/models/vm_or_template.rb       |  2 +-
 vmdb/spec/models/miq_report_spec.rb     | 56 +++++++++++++++++++++++++++++++++
 vmdb/spec/models/vm_or_template_spec.rb | 26 +++++++++++++++
 3 files changed, 83 insertions(+), 1 deletion(-)
Comment 6 Aziza Karol 2016-03-21 07:25:18 EDT
No error while executing a report.Able to create a report for listing all VMs with thin provision disk.

Verified:5.4.5.2


Verification steps:
1. Navigate to Cloud Intelligence ==> Reports ==> Reports.
2. Configuration ==> Add a new Report
3. In Columns tab, enter Name and Title ==? In Base the report on select "Template" 
4. In Editing report, select "Provisioned VMs:Name"
5. In Consolidation, Column 1 ==> Provisioned VMs:Name
6. In Filter, set following condition:
    FIND Template.Provisioned VMs : Thin Provisioned = "true" CHECK ALL Thin Provisioned = "true"
7. In Summary, Sort report by ==>  Provisioned VMs:Name
8. Save
9. Now Queue it.
Comment 8 errata-xmlrpc 2016-03-29 10:17:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0171.html

Note You need to log in before you can comment on or make changes to this bug.