Bug 1304011 - Replace resource agent NovaCompute with nova-compute-wait
Replace resource agent NovaCompute with nova-compute-wait
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: resource-agents (Show other bugs)
7.2
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Oyvind Albrigtsen
Asaf Hirshberg
: ZStream
Depends On:
Blocks: 1304811
  Show dependency treegraph
 
Reported: 2016-02-02 11:43 EST by Raoul Scarazzini
Modified: 2016-11-03 20:01 EDT (History)
11 users (show)

See Also:
Fixed In Version: resource-agents-3.9.5-57.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1304811 (view as bug list)
Environment:
Last Closed: 2016-11-03 20:01:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
New resource agent content (8.59 KB, application/x-shellscript)
2016-02-02 11:43 EST, Raoul Scarazzini
no flags Details

  None (edit)
Description Raoul Scarazzini 2016-02-02 11:43:37 EST
Created attachment 1120517 [details]
New resource agent content

In order to have instance migration working for ospd8 we need to change the behavior of the NovaCompute resource agent, making it forgot about managing the nova-compute process (which will be managed via systemd) and looking just for migration to finish.

The new resource agent will be named because of this nova-compute-wait and there is no need to keep the old one.

The content of the nova-compute-wait can be taken from the attachment.
Comment 7 Asaf Hirshberg 2016-03-08 03:19:06 EST
Verified on RHEL-OSP director 8.0 puddle - 2016-03-03.1

[heat-admin@overcloud-novacompute-0 ~]$  rpm -ql resource-agents-3.9.5-54.el7_2.6.x86_64 | grep nova-compute-wait
/usr/lib/ocf/resource.d/openstack/nova-compute-wait
/usr/share/man/man7/ocf_heartbeat_nova-compute-wait.7.gz
[heat-admin@overcloud-novacompute-0 ~]$
Comment 9 errata-xmlrpc 2016-11-03 20:01:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2174.html

Note You need to log in before you can comment on or make changes to this bug.