This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1304811 - Replace resource agent NovaCompute with nova-compute-wait
Replace resource agent NovaCompute with nova-compute-wait
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: resource-agents (Show other bugs)
7.2
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Oyvind Albrigtsen
cluster-qe@redhat.com
: ZStream
Depends On: 1304011
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 11:57 EST by Marcel Kolaja
Modified: 2016-02-16 06:17 EST (History)
13 users (show)

See Also:
Fixed In Version: resource-agents-3.9.5-54.el7_2.6
Doc Type: Bug Fix
Doc Text:
Cause: In order to have instance migration working for ospd8 we need to change the behavior of the NovaCompute resource agent, making it forgot about managing the nova-compute process (which will be managed via systemd) and looking just for migration to finish. Consequence: The nova-compute process needs to be managed via systemd and the resource agent needs to wait for migration to finish. Fix: Let systemd control the nova-compute process and nova-compute-wait wait for migration to finish. Result: Works as intended for instance migration.
Story Points: ---
Clone Of: 1304011
Environment:
Last Closed: 2016-02-16 06:17:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcel Kolaja 2016-02-04 11:57:58 EST
This bug has been copied from bug #1304011 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 4 Oyvind Albrigtsen 2016-02-05 04:38:45 EST
Before:
# ls /usr/lib/ocf/resource.d/openstack/
NovaCompute  NovaEvacuate

After:
# ls /usr/lib/ocf/resource.d/openstack/
nova-compute-wait  NovaEvacuate
Comment 7 errata-xmlrpc 2016-02-16 06:17:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0217.html

Note You need to log in before you can comment on or make changes to this bug.