Bug 1304019 - [NovaEvacuate] Fabric fencing devices do not support reboot action
[NovaEvacuate] Fabric fencing devices do not support reboot action
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: resource-agents (Show other bugs)
7.2
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Oyvind Albrigtsen
Ofer Blaut
: ZStream
Depends On: 1287303
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-02 12:04 EST by Marcel Kolaja
Modified: 2016-02-16 06:17 EST (History)
10 users (show)

See Also:
Fixed In Version: resource-agents-3.9.5-54.el7_2.4
Doc Type: Bug Fix
Doc Text:
Cause: We are changing the way fence_compute advertises itself in Bug #1287301, as a result it will no longer support the 'reboot' action causing evacuations to fail. Consequence: 'reboot' action will fail. Fix: Change to 'off' action. Result: Succeeds with 'off' action.
Story Points: ---
Clone Of: 1287303
Environment:
Last Closed: 2016-02-16 06:17:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcel Kolaja 2016-02-02 12:04:42 EST
This bug has been copied from bug #1287303 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 3 Oyvind Albrigtsen 2016-02-04 10:50:12 EST
Before:
# grep " -o .* -n " /usr/lib/ocf/resource.d/openstack/NovaEvacuate 
	    fence_compute ${fence_options} -o reboot -n $node

After:
# grep " -o .* -n " /usr/lib/ocf/resource.d/openstack/NovaEvacuate 
	    fence_compute ${fence_options} -o off -n $node
Comment 7 errata-xmlrpc 2016-02-16 06:17:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0217.html

Note You need to log in before you can comment on or make changes to this bug.