Bug 1304020 - [RFE] Automated Deployment of Instance HA in Director/Openstack
[RFE] Automated Deployment of Instance HA in Director/Openstack
Status: CLOSED DUPLICATE of bug 1264181
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
8.0 (Liberty)
x86_64 Linux
unspecified Severity medium
: ---
: 10.0 (Newton)
Assigned To: Hugh Brock
Shai Revivo
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-02 12:04 EST by Freddy Wissing
Modified: 2016-11-16 07:58 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-16 07:58:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2661641 None None None 2016-09-27 07:33 EDT

  None (edit)
Description Freddy Wissing 2016-02-02 12:04:43 EST
Automated deployment of Instance HA would be a desirable feature to include in Director/Openstack.

For this customer it was one of their requirements in the initial engagement and is currently automated in Spinal Stack for them.  It's of particular interest to obsolete their use of Spinal Stack by building those features into contemporary versions of RHOSP.  

Currently OSPd will partially deploy some of instance HA; however pacemaker remote requires additional manual configuration to complete the setup.  

It would be highly desirable if this could be defined, and the conducted via the deployment of the overcloud.

=======

Correction on this one.  There is a post process script that runs after spinal stack does the deploy that configures pacemaker remote and instance ha for them.  Director does in fact partially deploy some of this but it would be great if it would completely deploy the proper configuration as well as possibly including a test to validate the config or simulate instance fail over.
Comment 2 Mike Burns 2016-04-07 17:07:13 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 4 Ruchika K 2016-11-09 16:54:17 EST
On a related note I would like comments on this use case

All documentation states that once isntance HA is turned on upgrades are out of the question. My question is 

- Can instance HA be turned off after being turned on ?
Is it possible to follow these steps at all ?
- If I manually turned on Instance HA
- Can manual steps be followed to turn it off ?
- If the above answer is yes, can I then proceed to do an upgrade ?

Thank you!!
Comment 5 Fabio Massimo Di Nitto 2016-11-16 07:58:08 EST

*** This bug has been marked as a duplicate of bug 1264181 ***

Note You need to log in before you can comment on or make changes to this bug.