Bug 1264181 - [RFE] [HA] Integrate Instance HA feature with director for automatic deployment and updates.
Summary: [RFE] [HA] Integrate Instance HA feature with director for automatic deployme...
Keywords:
Status: CLOSED ERRATA
Alias: None
Deadline: 2018-04-23
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Upstream M1
: 13.0 (Queens)
Assignee: Michele Baldessari
QA Contact: Udi Shkalim
URL: https://blueprints.launchpad.net/trip...
Whiteboard: upstream_milestone_pike-2 upstream_de...
: 1185030 1251948 1304020 1411649 1417349 1465542 (view as bug list)
Depends On: 1242422 1379741 1558241 1562747 1567606 1570429 1582827 1649253 1654641
Blocks: 1182956 1419948 1422243 1442136 1458798 1465537 1185030 1251948 1261487 1417349 1484174 1487994 1488696 1488697 1538790 1598714
TreeView+ depends on / blocked
 
Reported: 2015-09-17 18:21 UTC by Stephen Gordon
Modified: 2020-09-20 13:27 UTC (History)
38 users (show)

Fixed In Version: puppet-tripleo-8.2.0-0.20180122224519.9fd3379.el7ost openstack-tripleo-heat-templates-8.0.0-0.20180122224017.el7ost
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:26:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 506350 'None' MERGED Add Instance HA support 2020-09-21 06:06:29 UTC
OpenStack gerrit 506922 'None' MERGED Instance HA support 2020-09-21 06:06:30 UTC
Red Hat Knowledge Base (Article) 1544823 None None None 2019-06-13 08:12:14 UTC
Red Hat Knowledge Base (Solution) 1365313 Configure None High availability in OpenStack Platform for traditional application workloads 2019-06-13 08:12:14 UTC
Red Hat Knowledge Base (Solution) 2661641 None None None 2016-12-14 05:18:38 UTC
Red Hat Product Errata RHEA-2018:2086 normal SHIPPED_LIVE Red Hat OpenStack Platform 13.0 Enhancement Advisory 2018-06-28 19:51:39 UTC

Description Stephen Gordon 2015-09-17 18:21:28 UTC
Description of problem:

Currently the instance HA feature is configured manually using a complex series of commands but will be blow away by future OSP-d updates:

    https://access.redhat.com/node/1544823/

We need to re-work the instructions to provide an environment file suitable for inclusion in the Kbase if not shipped directly with Director. This would be a first step to integrating the instance HA feature.

Version-Release number of selected component (if applicable):

RHEL OpenStack Platform 7

Comment 1 Stephen Gordon 2015-11-12 19:14:13 UTC
Hi Keith,

This has remained untriaged for a while - was originally targeting 7.0 y2 (this was all the reason for the clawed back scope of just providing a yaml file) - and at this point it remains unclear who is doing the work. We have a documented list of the steps required to enable this post-deploy, we need to be able to do it as part of deployment by default (and optionally disabled).

Thanks,

Steve

Comment 5 Andrew Beekhof 2016-01-05 21:34:38 UTC
Chris, why are you assigning this to me?
I have no knowledge of how to modify director

Comment 6 Jaromir Coufal 2016-01-07 10:07:01 UTC
Rob/Andrew, who is working on this feature from HA team? Can we assign the person who is responsible? Thanks, Jarda

Comment 7 Mike Burns 2016-04-07 20:50:54 UTC
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.

Comment 9 Rob Young 2016-05-17 12:38:27 UTC
(In reply to Mike Burns from comment #7)
> This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.

Instance HA remains a fully supported, manually deployed and updated feature in OSP 8 and OSP 9. The scope of this request has been extended such that Instance HA will be integrated with director so that it is automatically deployed and updated on the new, single HA architecture that will be implemented in OSP 10. This has been discussed and scoped with the Pidone Eng team and factored into the PM plan for OSP 10 delivery.

Comment 12 Rob Young 2016-10-06 17:42:44 UTC
@eglynn Ack on the need for InstallerIntegration keyword on this RFE. Thanks for setting this.

Comment 15 Fabio Massimo Di Nitto 2016-11-16 12:52:19 UTC
*** Bug 1185030 has been marked as a duplicate of this bug. ***

Comment 16 Fabio Massimo Di Nitto 2016-11-16 12:58:08 UTC
*** Bug 1304020 has been marked as a duplicate of this bug. ***

Comment 17 Fabio Massimo Di Nitto 2016-11-16 13:00:20 UTC
*** Bug 1251948 has been marked as a duplicate of this bug. ***

Comment 23 Fabio Massimo Di Nitto 2017-01-12 04:29:54 UTC
Moving to OSP12. Not enough time left for OSP11 and dependencies have not all landed in OSP11 yet.

Comment 24 Stephen Gordon 2017-01-18 19:57:56 UTC
*** Bug 1411649 has been marked as a duplicate of this bug. ***

Comment 25 Rob Young 2017-03-14 20:37:09 UTC
Removing need-info flag on this. This is now moved to OSP 12.

Comment 33 Chris Jones 2017-10-25 15:18:16 UTC
*** Bug 1465542 has been marked as a duplicate of this bug. ***

Comment 37 pkomarov 2018-05-02 11:31:47 UTC
Verified , 

feature has been tested and found to be working.

Comment 38 Sean Merrow 2018-05-18 19:55:44 UTC
*** Bug 1417349 has been marked as a duplicate of this bug. ***

Comment 40 errata-xmlrpc 2018-06-27 13:26:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.