Bug 1304023 - [RFE] Veth interfaces need to be created by director and persistent through reboots.
[RFE] Veth interfaces need to be created by director and persistent through r...
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Hugh Brock
Shai Revivo
: FutureFeature
: 1304021 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-02 12:09 EST by Freddy Wissing
Modified: 2017-02-15 11:19 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-15 11:19:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Freddy Wissing 2016-02-02 12:09:47 EST
Customer presently makes use of veth in their deployment.  

These veths are made persistent across reboots by the manual creation of systemctl units that execute during boot.  

A cleaner and more manageable way of dealing with this would be if the veth could have an ifcfg script as other interfaces do which could then get deployed in an advanced network config manner with director.
Comment 2 Mike Burns 2016-02-03 11:42:42 EST
*** Bug 1304021 has been marked as a duplicate of this bug. ***
Comment 3 Mike Burns 2016-04-07 17:07:13 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 5 Dan Sneddon 2016-12-06 09:57:42 EST
(In reply to Freddy Wissing from comment #0)
> Customer presently makes use of veth in their deployment.  
> 
> These veths are made persistent across reboots by the manual creation of
> systemctl units that execute during boot.  
> 
> A cleaner and more manageable way of dealing with this would be if the veth
> could have an ifcfg script as other interfaces do which could then get
> deployed in an advanced network config manner with director.

Hello Freddy, I'm taking a look at this bug, and I don't actually understand the ask. Perhaps if you included an example of what the user is doing with the sysctl files, I could examine whether we could have the os-net-config utility generate ifcfg files.

Without knowing what the purpose of the veth is, I'm not sure I can imagine how this feature would work.

Can you please describe in more detail how the veth interfaces are used?
Comment 6 Freddy Wissing 2017-02-15 11:19:00 EST
Hi Dan, 

The customer isn't pursuing this anymore due to some internal decisions so we can go ahead and close the bug.  

Thanks, 

/Freddy

Note You need to log in before you can comment on or make changes to this bug.