Bug 130403 - File exists: '/mnt/sysimage/selinux' and anaconda crashes out
File exists: '/mnt/sysimage/selinux' and anaconda crashes out
Status: CLOSED DUPLICATE of bug 127713
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-19 21:12 EDT by Colin Charles
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Charles 2004-08-19 21:12:41 EDT
Description of problem: Doing an upgrade from Fedora Core 2 to Fedora
Core 3 test1, using the CD media on a Thinkpad T20, not running
SELinux, with all FC2 updates applied, provided an error message and
then crashed out.

How reproducible: Twice, I tried it. Willing to say "everytime"


Steps to Reproduce:
1. Insert FC3 test1 CD into drive
2. Start installation process
3. Select Upgrade
4. Wait till it transfers install image to hard drive
  
Actual results:
Traceback (most recent call last):
File "/usr/lib/anaconda/gui.py", line 1057, in handleRenderCallback
self.current Window.renderCallback()
File "/usr/lib/anaconda/iw/progress_gui.py", line 242, in
renderCallback self.intf.icw.nextClicked()
File "/usr/lib/anaconda/gui.py", line 772, in nextClicked
self.dispatch.gotoNext()
File "/usr/lib/anaconda/dispatch.py", line 169, in gotoNext
self.moveStep()
File "/usr/lib/anaconda/dispatch.py", line 237, in moveStep rc =
apply(func, self.bindArgs(args__
File "/usr/lib/anaconda/packages.py", line 737, in doPreInstall
os.mkdir(instPath + "/selinux")
OSError: [Errno 17] File exists: '/mnt/sysimage/selinux'

Expected results:
Installation continues

Additional info: Offer to get to the debugger is present, otherwise,
reboot. Willing to do debugging if need be; I still didn't wipe FC2
off the box just in case there are some anaconda weirdness we can fix
because of it
Comment 1 Jeremy Katz 2004-08-19 21:29:13 EDT

*** This bug has been marked as a duplicate of 127713 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:10 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.