Bug 1304065 - [RFE] UI should expose regex validation checks to TextBoxArea
[RFE] UI should expose regex validation checks to TextBoxArea
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity unspecified
: GA
: 5.6.0
Assigned To: Milan Zázrivec
Taras Lehinevych
: FutureFeature
: 1304066 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-02 14:20 EST by Jeff Warnica
Modified: 2016-08-02 21:33 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:35:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1348 normal SHIPPED_LIVE CFME 5.6.0 bug fixes and enhancement update 2016-06-29 14:50:04 EDT

  None (edit)
Description Jeff Warnica 2016-02-02 14:20:28 EST
Per summary.

The code supports this, and import/export with YAML can make this happen. The UI doesn't have the ability to view, or edit, however.
Comment 2 Jeff Warnica 2016-02-02 14:22:21 EST
*** Bug 1304066 has been marked as a duplicate of this bug. ***
Comment 3 Shveta 2016-02-02 19:14:50 EST
Assigning to add test case
Comment 5 Milan Zázrivec 2016-02-29 11:25:49 EST
https://github.com/ManageIQ/manageiq/pull/7001
Comment 6 CFME Bot 2016-03-02 12:25:34 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/8aedafbc219f1beb138f38e11b60f0ff9523a9b6

commit 8aedafbc219f1beb138f38e11b60f0ff9523a9b6
Author:     Milan Zazrivec <mzazrivec@redhat.com>
AuthorDate: Tue Feb 23 11:03:40 2016 +0100
Commit:     Milan Zazrivec <mzazrivec@redhat.com>
CommitDate: Mon Feb 29 16:31:19 2016 +0100

    Add regexp validation to text area in service dialog editor
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1304065

 app/controllers/miq_ae_customization_controller/dialogs.rb  | 10 +++++-----
 app/views/miq_ae_customization/_dialog_field_form.html.haml |  2 +-
 2 files changed, 6 insertions(+), 6 deletions(-)
Comment 7 Taras Lehinevych 2016-04-28 05:10:21 EDT
Verified in 5.6.0.4-beta2.3
Comment 9 errata-xmlrpc 2016-06-29 11:35:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.