Bug 1304099 - Master resets client_secret on startup. Breaks native ha
Master resets client_secret on startup. Breaks native ha
Status: CLOSED DUPLICATE of bug 1302946
Product: OpenShift Container Platform
Classification: Red Hat
Component: Auth (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jordan Liggitt
weiwei jiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-02 16:31 EST by Wesley Hearn
Modified: 2016-10-30 18:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-02 16:33:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wesley Hearn 2016-02-02 16:31:21 EST
Description of problem:
each master is resetting the client_secret for the internal oauth client on startup

Version-Release number of selected component (if applicable):
3.1.1.6

How reproducible:
Always

Steps to Reproduce:
1. Spin up a native ha cluster
2. oc login <api>
3. goto page and see Error getting token: Invalid status code (400): 400 Bad Request 


Actual results:
400 error

Expected results:
Able to get auth token

Additional info:
Comment 1 Jordan Liggitt 2016-02-02 16:33:30 EST

*** This bug has been marked as a duplicate of bug 1302946 ***

Note You need to log in before you can comment on or make changes to this bug.