Bug 1302946 - Sometime can't get token when access token/request api in v3 stage env
Sometime can't get token when access token/request api in v3 stage env
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Auth (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Jordan Liggitt
weiwei jiang
: TestBlocker
: 1304099 1306351 (view as bug list)
Depends On:
Blocks: OSOPS_V3
  Show dependency treegraph
 
Reported: 2016-01-29 00:57 EST by DeShuai Ma
Modified: 2016-02-23 15:31 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-23 15:31:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description DeShuai Ma 2016-01-29 00:57:22 EST
Description of problem:
Can't request token in v3 stage env, always return error "Error getting token: Invalid status code (400): 400 Bad Request"

Version-Release number of selected component (if applicable):
latest stage env.

How reproducible:
sometime

Steps to Reproduce:
1.In web access token request url
https://<stage_api_server>/oauth/token/request

Actual results:
1.Error getting token: Invalid status code (400): 400 Bad Request 

Expected results:
1.Get token success

Additional info:
Comment 1 Jordan Liggitt 2016-01-29 11:43:22 EST
What is in the master logs when this occurs?
Comment 2 DeShuai Ma 2016-01-31 20:31:34 EST
(In reply to Jordan Liggitt from comment #1)
> What is in the master logs when this occurs?

We can't get the master logs, the env is provided by ops, we have no permission to access the master and node. When test on the env, this happened very often
Comment 3 Jordan Liggitt 2016-02-02 16:33:30 EST
*** Bug 1304099 has been marked as a duplicate of this bug. ***
Comment 4 Jordan Liggitt 2016-02-02 17:20:14 EST
Fix upstream in https://github.com/openshift/origin/pull/6982/
Comment 5 DeShuai Ma 2016-02-03 01:04:36 EST
This bug test block our v3 stage test, high this bug.
Comment 6 Jordan Liggitt 2016-02-03 01:08:21 EST
Until the fix is deployed, you can get a token by logging into the web console and running this in the javascript console:

prompt("Token",localStorage["LocalStorageUserStore.token"])

That token can be taken to the console for testing.
Comment 7 Wesley Hearn 2016-02-03 17:07:01 EST
We have deployed a hotfix it should be working now.
Comment 8 Wei Sun 2016-02-03 21:21:56 EST
Verified this bug against v3 stage,now we could get token via accessing oauth/token/request page.
Comment 10 Jordan Liggitt 2016-02-05 15:30:37 EST
Fix is in OSE in https://github.com/openshift/ose/commit/5d69528c759aceaed3ce3bebcee3da6deedd7592

I think that means it will be in the next 3.1.x update.
Comment 11 Miheer Salunke 2016-02-11 03:53:49 EST
*** Bug 1306351 has been marked as a duplicate of this bug. ***
Comment 14 errata-xmlrpc 2016-02-23 15:31:55 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0293

Note You need to log in before you can comment on or make changes to this bug.