This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1304111 - RHEL-OSP Does not Have Support for the Manila Horizon UI Plugin
RHEL-OSP Does not Have Support for the Manila Horizon UI Plugin
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-manila-ui (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity high
: beta
: 10.0 (Newton)
Assigned To: hguemar
Dustin Schoenbrun
: Triaged
Depends On:
Blocks: 1285516
  Show dependency treegraph
 
Reported: 2016-02-02 17:17 EST by Dustin Schoenbrun
Modified: 2016-12-14 10:22 EST (History)
10 users (show)

See Also:
Fixed In Version: openstack-manila-ui-1.2.0-1.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-14 10:22:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
No Manila UI (81.85 KB, image/png)
2016-04-06 07:04 EDT, Ido Ovadia
no flags Details

  None (edit)
Description Dustin Schoenbrun 2016-02-02 17:17:05 EST
Description of problem:
Currently there is no release of the Manila Horizon UI Plugin for OSP-8 so there is no way to manage your Manila infrastructure through the Horizon UI. There is a branch available for this for OSP-7 but nothing for OSP-8.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Attempt to install the "openstack-manila-ui" package in OSP-8
2. Observe that the package is not available.
3.

Actual results:
There is no package named "openstack-manila-ui"

Expected results:
The Manila Horizon UI Plugin shall be installed successfully.

Additional info:
Comment 3 Jon Schlueter 2016-02-23 09:04:07 EST
cross-tagged build from osp 7
Comment 4 hguemar 2016-02-23 11:39:41 EST
New build (rebased to 1.2.0)
Comment 7 Dave Cain 2016-03-20 11:20:50 EDT
Installed openstack-manila-ui in RHEL-OSP8 Beta 7.

I can confirm that after restarting httpd, a "Shares" tab appears to the right of the "Access & Security" tab in Horizon.
Comment 8 Ido Ovadia 2016-04-06 07:04 EDT
Created attachment 1144192 [details]
No Manila UI
Comment 9 Ido Ovadia 2016-04-06 07:10:41 EDT
Failed QA
=========

Was Verified on HA Director deployment.

For each overcloud-controller (3):
==================================
openstack-manila-1.0.1-3.el7ost.noarch
openstack-manila-ui-1.2.0-1.el7ost.noarch
openstack-manila-share-1.0.1-3.el7ost.noarch

and,

systemctl restart httpd


Actual results:
===============
There is no "Shares" tab on Horizon

Screenshot is enclosed.
Comment 11 Sean Cohen 2016-07-26 16:00:35 EDT
Dustin,
Can you validate this one in the context of https://bugzilla.redhat.com/show_bug.cgi?id=1285516?
Sean
Comment 12 Dustin Schoenbrun 2016-07-26 23:39:53 EDT
(In reply to Sean Cohen from comment #11)
> Dustin,
> Can you validate this one in the context of
> https://bugzilla.redhat.com/show_bug.cgi?id=1285516?
> Sean

Sure thing. When I get some bits for OSP-10 I'll make sure that I can install the Horizon Plugin via OSP-Director and that it functions properly. I'll create new bugs for anything that I find outside of the installation of the UI plugin.
Comment 14 Dustin Schoenbrun 2016-10-17 12:17:36 EDT
Tested with 2016-10-6.1 puddle version and can verify that the Manila UI is available in the openstack-manila-ui package and it is also installed with OSP-Director. Looks good to me!
Comment 17 errata-xmlrpc 2016-12-14 10:22:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html

Note You need to log in before you can comment on or make changes to this bug.