Bug 1285516 - [RFE] Deploy Manila UI plugin in RHEL-OSP director
[RFE] Deploy Manila UI plugin in RHEL-OSP director
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-puppet-elements (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity unspecified
: rc
: 10.0 (Newton)
Assigned To: Erno Kuvaja
Dustin Schoenbrun
: FutureFeature, InstallerIntegration, Triaged
Depends On: 1304111
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-25 14:51 EST by Sean Cohen
Modified: 2017-01-26 01:35 EST (History)
17 users (show)

See Also:
Fixed In Version: openstack-tripleo-puppet-elements-5.0.0-0.20160902162220.01fb147.el7ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-14 10:18:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 355394 None None None 2016-08-15 05:45 EDT

  None (edit)
Description Sean Cohen 2015-11-25 14:51:51 EST
The Manila UI Plugin support was added in Horizon in RHEL-OSP7 (bug 1243445).

However, currently you need to install the Manila-UI package manually as well as to restart the httpd service for it to pick up the changes. 

This RFE goal is to simplify the deployment of the Manila UI plugin into Horizon with minimal interaction using RHEL-OSP director.
Comment 3 Elise Gafford 2016-07-27 13:46:26 EDT
Hi Erno,

As a note, the Manila UI installation into the controller image may well be as simple as Sahara's (see https://review.openstack.org/#/c/346213/).
Comment 4 Erno Kuvaja 2016-08-10 10:34:14 EDT
Hopefull can get this in on time before FF.
Comment 5 Erno Kuvaja 2016-08-15 05:45:50 EDT
Change submitted to OpenStack gerrit
Comment 6 Erno Kuvaja 2016-08-19 08:07:15 EDT
Should not have been on post yet. Still waiting for reviews
Comment 7 Erno Kuvaja 2016-08-29 05:41:24 EDT
Now the change got merged upstream.
Comment 8 Elise Gafford 2016-09-08 12:08:28 EDT
Hi Erno,

Please add the fixed-in-build in which this RFE is built so it can be shipped to QE.
Comment 10 Erno Kuvaja 2016-09-19 07:10:40 EDT
(In reply to Elise Gafford from comment #8)
> Hi Erno,
> 
> Please add the fixed-in-build in which this RFE is built so it can be
> shipped to QE.

I have no idea in which build it has been fixed.
Comment 13 Dustin Schoenbrun 2016-10-17 12:38:56 EDT
Tested with the 2016-10-06.1 puddle and the Manila Horizon UI Plugin is installed correctly with OSP-Director on the first controller node.
Comment 16 errata-xmlrpc 2016-12-14 10:18:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html

Note You need to log in before you can comment on or make changes to this bug.