This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 130421 - should run "restorecon $FONT_UNIX_DIR" for SE Linux
should run "restorecon $FONT_UNIX_DIR" for SE Linux
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
: 130969 (view as bug list)
Depends On:
Blocks: FC3Blocker FC3SELinux
  Show dependency treegraph
 
Reported: 2004-08-20 08:54 EDT by Russell Coker
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-15 02:49:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Russell Coker 2004-08-20 08:54:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, like Gecko)

Description of problem:
After creating $FONT_UNIX_DIR the start script should run:
text -s /sbin/restorecon && /sbin/restorecon $FONT_UNIX_DIR

This will set the SE Linux context of the new directory to the correct type.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Boot SE Linux and run "ls -ldZ /tmp/.font-unix", observe that the context is system_u:object_r:initrc_tmp_t not system_u:object_r:xfs_tmp_t .

Additional info:
Comment 1 Mike A. Harris 2004-09-15 02:49:43 EDT
Added to 6.8.0-5 in CVS, will appear in rawhide after FC3t2.
Comment 2 Mike A. Harris 2004-09-15 17:59:21 EDT
*** Bug 130969 has been marked as a duplicate of this bug. ***
Comment 3 Mike A. Harris 2004-09-15 18:02:41 EDT
I've updated the fix for this to move the call to restorecon down
after the chmod/chown as the patch in bug 130969 does, in case
chmod/chown cause problems after restorecon, just to be safe.

This new fix will be in 6.8.0-6

Note You need to log in before you can comment on or make changes to this bug.