Bug 130969 - xfs socket startup fails; /tmp/.font-unix labeled incorrectly
xfs socket startup fails; /tmp/.font-unix labeled incorrectly
Status: CLOSED DUPLICATE of bug 130421
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks: FC3Blocker
  Show dependency treegraph
 
Reported: 2004-08-26 05:06 EDT by Leonard den Ottolander
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Restorecon patch for xfs startup script (314 bytes, text/plain)
2004-09-09 13:22 EDT, Daniel Walsh
no flags Details

  None (edit)
Description Leonard den Ottolander 2004-08-26 05:06:50 EDT
selinux-policy-strict-1.17.2-1

I'm seeing the following at startup. I have to boot to runlevel 3
because X won't start since it "could not open default font 'fixed'".
Service xfs is reported running but non functional.

Aug 25 23:27:36 k6-joy xfs: xfs startup succeeded
Aug 25 23:27:36 k6-joy kernel: audit(1093469256.744:0): avc: denied  {
getattr } for  pid=2171 exe=/usr/X11R6/bin/xfs path=/tmp/.font-unix
dev=hda6 ino=425186
scontext=system_u:system_r:xfs_ttcontext=system_u:object_r:initrc_tmp_t
tclass=dir
Aug 25 23:27:36 k6-joy xfs[2171]: cannot establish any listening sockets
Aug 25 23:27:37 k6-joy xfs[2171]: ignoring font path element
/usr/X11R6/lib/X11/fonts/Speedo (unreadable)

Running a fixfiles relabel did not fix this issue. Removing
/tmp/.font-unix by hand and rebooting doesn't fix the situation:

root      2372  0.5  0.8 12196 2304 ?        Ss   01:11   0:00
/usr/bin/gdm-binary -nodaemon
root      2917  0.1  0.4  5312 1120 ?        Ss   01:11   0:00
/bin/sh/etc/X11/gdm/XKeepsCrashing
root      2934  0.0  0.0  2432  252 ?        S    01:11   0:00
/usr/libexec/gdmopen -l /bin/sh -c /etc/X11/gdm/XKeepsCrashing -noopen 
root      2947  0.3  0.4  5168 1124 tty8     Ss+  01:11   0:00
/bin/sh/etc/X11/gdm/XKeepsCrashing -noopen
root      3007  0.0  0.3  5020 1016 tty8     S+   01:11   0:00
/usr/bin/dialog --yesno I cannot start the X server (your
graphicalinterface).  It is likely that it is not set up correctly. 
Would youlike to view the X server output to diagnose the problem? 10 50

[root@k6-joy tmp]# ls -aZd .font-unix
drwxrwxrwt  root     root     system_u:object_r:initrc_tmp_t  .font-unix
Comment 1 Leonard den Ottolander 2004-08-26 10:23:01 EDT
On Thu, 2004-08-26 at 14:06, Stephen Smalley wrote:
/etc/init.d/xfs needs to restorecon /tmp/.font-unix after re-creating
it (previously, it was getting re-created by xfs itself, and the
policy automatically put it into the right type using a
file_type_auto_trans rule from xfs_t).
Comment 2 Daniel Walsh 2004-09-09 13:22:58 EDT
Created attachment 103644 [details]
Restorecon patch for xfs startup script

This patch will work whether or not SELinux is enabled, since restorecon will
exit 0 if it is not enabled.
Comment 5 Leonard den Ottolander 2004-11-03 15:51:08 EST
Why was this report closed a duplicate? And a duplicate of which bug
would it be?
Comment 6 Red Hat Bugzilla 2006-02-21 14:05:18 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.