Bug 1304364 - [ppc64le] Failed to cancel migration
[ppc64le] Failed to cancel migration
Status: CLOSED DUPLICATE of bug 1304354
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
3.6.0.3
ppc64le Unspecified
unspecified Severity high (vote)
: ---
: ---
Assigned To: Michal Skrivanek
Israel Pinto
:
Depends On:
Blocks: RHEV3.6PPC
  Show dependency treegraph
 
Reported: 2016-02-03 07:26 EST by Israel Pinto
Modified: 2016-02-21 05:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-03 09:42:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
ipinto: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
logs (1.95 MB, application/zip)
2016-02-03 07:26 EST, Israel Pinto
no flags Details

  None (edit)
Description Israel Pinto 2016-02-03 07:26:26 EST
Created attachment 1120737 [details]
logs

Description of problem:
Start Migrate VM, cancel VM migration, cancelling failed.
2016-02-03 14:15:03,948 ERROR [org.ovirt.engine.core.bll.CancelMigrateVmCommand] (org.ovirt.thread.pool-6-thread-42) [761e03cf] Command 'org.ovirt.engine.core.bll.CancelMigrateVmCommand' failed: EngineException: org.ovirt.engine.core.vdsbroker.vdsbroker.VDSErrorException: VDSGenericException: VDSErrorException: Failed to CancelMigrateVDS, error = Migration not in progress, code = 47 (Failed with error MIGRATION_CANCEL_ERROR and code 47)


Version-Release number of selected component (if applicable):
RHEVM Version: 3.6.3-0.1.el6
vdsm-4.17.19-0.el7ev
libvirt-1.2.17-13.el7_2.3
KVM: 2.3.0 - 31.el7_2.7
kernel: 3.10.0 - 327.10.1.el7.ppc64le

How reproducible:
100%

Steps to Reproduce:
1. Start VM 
2. Migrate VM from engine
3. Cancel VM from engine

Actual results:
Cancel migration failed
2016-02-03 14:15:03,948 ERROR [org.ovirt.engine.core.bll.CancelMigrateVmCommand] (org.ovirt.thread.pool-6-thread-42) [761e03cf] Command 'org.ovirt.engine.core.bll.CancelMigrateVmCommand' failed: EngineException: org.ovirt.engine.core.vdsbroker.vdsbroker.VDSErrorException: VDSGenericException: VDSErrorException: Failed to CancelMigrateVDS, error = Migration not in progress, code = 47 (Failed with error MIGRATION_CANCEL_ERROR and code 47)

Adding logs
Comment 1 Israel Pinto 2016-02-03 07:54:51 EST
Note that memory hotplug is enabled
Comment 2 Michal Skrivanek 2016-02-03 09:42:21 EST
libvirtError: internal error: process exited while connecting to monitor: 2016-02-03T12:14:51.218641Z qemu-kvm: Failed to allocate HTAB of requested size, try with s
maller maxmem

closing as duplicate of bug 1304354 (actual root cause is bug 1304300)

*** This bug has been marked as a duplicate of bug 1304354 ***

Note You need to log in before you can comment on or make changes to this bug.