Bug 1304371 - Intel Skylake Grahics wrong resolution/out of sync for 2nd and 3rd monitor with kernels from 4.5.0-0.rc0.git8.2.fc24.x86_64 up to 4.5.0-0.rc2.git1.2.fc24
Intel Skylake Grahics wrong resolution/out of sync for 2nd and 3rd monitor wi...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-03 07:40 EST by Konstantinos Togias
Modified: 2016-02-20 12:07 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-20 12:06:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vvvxxx output lshw -sanitize output dmidecode output xrandr -q --verbose output lsmod output uname -a output journalctl -b output till "Startup finished" from both working and not working kern (63.79 KB, application/x-bzip)
2016-02-03 07:40 EST, Konstantinos Togias
no flags Details

  None (edit)
Description Konstantinos Togias 2016-02-03 07:40:04 EST
Created attachment 1120759 [details]
lspci -vvvxxx output lshw -sanitize output dmidecode output xrandr -q --verbose output lsmod output uname -a output journalctl -b output till "Startup finished" from both working and not working kern

Description of problem:
I recently upgraded my fedora 23 PC with a SkyLake Intel Core i7 6700 (1151/3.40 GHz/8 MB) CPU and an MSI Motherboard Z170A Gaming M7 (Z170/1151/DDR4). As various components of the new setup where not supported by fedora updates kernels (Skylake Graphics, Ethernet controller, Analog audio out) I went with fedora-rawhide-kernel-nodebug. While up to kernel 4.5.0-0.rc0.git1.2.fc24 graphics worked OK with 3 monitors connected (1 through displayport and 2 through hdmi), with newer rawhide kernels (4.5.0-0.rc0.git8.2, 4.5.0-0.rc1.git0.1 and 4.5.0-0.rc2.git1.2) I get only one monitor properly detected and configured with optimal resolution, while the other two reporting non-optimal resolution or input out of range. The selection of the monitor that is properly configured seems to be random. On some boots the DisplayPort monitor will be the one working while the other two not, on some other boots one of the HDMI monitors will be the one with proper resolution and the other two displaying input error message and going to sleep mode.  

Version-Release number of selected component (if applicable):
4.5.0-0.rc0.git1.2.fc24.x86_64 OK
4.5.0-0.rc0.git8.2.fc24.x86_64 PROBLEM
4.5.0-0.rc1.git0.1.fc24.x86_64 PROBLEM
4.5.0-0.rc2.git1.2.fc24.x86_64 PROBLEM

How reproducible:
Install 4.5.0-0.rc2.git1.2.fc24.x86_64 kernel from rawhide nodebug and reboot.


Actual results:
When on login screen 2 of the 3 monitors report non-optimal resolution or input out of range. 1 monitor works OK with optimal resolution. After login valid resolution options are available for misconfigured monitors in gnome settings, but selecting each of them has no effect.

Expected results:
All the 3 monitors should have been probed and automatically configured to the optimal resolution of each. After login, selecting resolutions from gnome settings should have an actual effect on the 2 misconfigured monitors.  

Additional info:
CPU: Intel Core i7 6700
MotherBorad: MSI Z170A Gaming M7

Attached:
I include for both 4.5.0-0.rc0.git1.2.fc24.x86_64 (Working OK) and 4.5.0-0.rc2.git1.2.fc24.x86_64 (PROBLEM) kernel the following outputs:

lspci -vvvxxx output
lshw -sanitize output
dmidecode output
xrandr -q --verbose output
lsmod output
uname -a output
journalctl -b output till "Startup finished"
Comment 1 Konstantinos Togias 2016-02-03 07:57:41 EST
I would also like to report that graphics with the 3 monitors works fine with the latest 4.3.4-300.fc23 kernel from updates
Comment 2 Konstantinos Togias 2016-02-10 11:49:33 EST
The problem occurs with the newer 4.5.0-0.rc3.git1.2.fc24 rawhidew kernel too.
Comment 3 davidgf 2016-02-10 16:52:57 EST
Might be connected to https://bugzilla.redhat.com/show_bug.cgi?id=1303262 ?

Thanks!
Comment 4 Konstantinos Togias 2016-02-19 10:35:21 EST
The problem remains with 4.5.0-0.rc3.git3.2.fc24 kernel. 

When booting this kernel I got the following repeating messages on text console:

drm: intel_dp_start_link_train [915] *ERROR* failed to train DP, aborting
drm: intel_dp_start_link_train [915] *ERROR* failed to train DP, aborting
.........[multiple times the same line]...........
drm: intel_dp_link_training_clock_recovery [i915] *ERROR* too many full retries give up
drm: intel_dp_start_link_train [915] *ERROR* failed to train DP, aborting
.........[multiple times the same line]...........
drm: intel_dp_link_training_clock_recovery [i915] *ERROR* too many full retries give up
.........
Comment 5 Konstantinos Togias 2016-02-20 12:06:37 EST
I just booted 4.5.0-0.rc4.git2.2.fc24.x86_64 rawhide nodebug kernel and all 3 monitors are configured and working correctly. So the problem seems to be solved. I close the bug report for the moment and I will come back if the problem appear again.

Note You need to log in before you can comment on or make changes to this bug.