Bug 1304612 - "Disabling the High-Availability Agents" not available in 3.6
"Disabling the High-Availability Agents" not available in 3.6
Status: CLOSED DUPLICATE of bug 1303716
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
All Linux
unspecified Severity low
: ---
: ---
Assigned To: nobody nobody
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 02:39 EST by Sistemas Amtega
Modified: 2016-03-20 06:02 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-20 06:02:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Hosted-engine VM option for maintenance (38.46 KB, image/png)
2016-02-04 04:38 EST, Doron Fediuck
no flags Details

  None (edit)
Description Sistemas Amtega 2016-02-04 02:39:22 EST
Description of problem:

The 3.6 documentation talks in https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6-Beta/html/Self-Hosted_Engine_Guide/chap-Backing_up_and_Restoring_a_RHEL-Based_Self-Hosted_Environment.html about "Disabling the High-Availability Agents":

"Disable the high-availability agents on the hosted-engine hosts to prevent migration of the Red Hat Enterprise Virtualization Manager virtual machine during the backup process. In the Administration Portal, click the Virtual Machines resource tab. Right-click the engine virtual machine, and select Enable Global HA Maintenance to set all hosts to the global maintenance mode."

The problem is that seems in version 3.6 this option is not available because is not possible to see the engine virtual machine within the manager.

Version-Release number of selected component (if applicable):

rhev-hypervisor7-7.2-20160120.0.iso

How reproducible:

Every time.

Steps to Reproduce:
1. Try to implement operations detailed in "https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6-Beta/html/Self-Hosted_Engine_Guide/chap-Backing_up_and_Restoring_a_RHEL-Based_Self-Hosted_Environment.html" related to "Disabling the High-Availability Agents":

Actual results:

The detailed operations are not available.

Expected results:

If this functionality is not available in this version it should be removed from documentation.
Comment 1 Doron Fediuck 2016-02-04 04:36:04 EST
(In reply to Sistemas Amtega from comment #0)
> Description of problem:
> 
> The 3.6 documentation talks in
> https://access.redhat.com/documentation/en-US/
> Red_Hat_Enterprise_Virtualization/3.6-Beta/html/Self-Hosted_Engine_Guide/
> chap-Backing_up_and_Restoring_a_RHEL-Based_Self-Hosted_Environment.html
> about "Disabling the High-Availability Agents":
> 
> "Disable the high-availability agents on the hosted-engine hosts to prevent
> migration of the Red Hat Enterprise Virtualization Manager virtual machine
> during the backup process. In the Administration Portal, click the Virtual
> Machines resource tab. Right-click the engine virtual machine, and select
> Enable Global HA Maintenance to set all hosts to the global maintenance
> mode."
> 
> The problem is that seems in version 3.6 this option is not available
> because is not possible to see the engine virtual machine within the manager.
> 

Hi,
this is related to the data domain explained in Bug 1304611.
Once you create it you'll be able to see the HE VM and the above option will become relevant.
Attaching a screenshot of the available options and closing this issue.
Comment 2 Doron Fediuck 2016-02-04 04:38 EST
Created attachment 1121053 [details]
Hosted-engine VM option for maintenance

Attaching a screenshot with relevant maintenance options for the HE VM.
Note that post installation you need to add the first data domain in order to
make this VM visible.
Comment 3 Sistemas Amtega 2016-02-04 04:53:17 EST
We already have created a data storage domain. In fact, we haver 192 virtual machines running on the Beta test platform.
Comment 4 Roy Golan 2016-02-10 04:22:33 EST
(In reply to Sistemas Amtega from comment #3)
> We already have created a data storage domain. In fact, we haver 192 virtual
> machines running on the Beta test platform.

this could be related to a former issue I saw for Xunta, that you used a different name for your hosted engine storage domain. The engine expecting 'hosted_storage' is unable to import that domain. 

try:

su - postgres
-bash-4.1$ psql engine -c "select fn_db_add_config_value('HostedEngineStorageDomainName','hosted_storage','general');"

echo HostedEngineStorageDomainName | engine-config  -s HostedEngineStorageDomainName="hosted_storage2" -p /dev/stdin
Comment 5 Sistemas Amtega 2016-02-11 07:46:47 EST
Hello,

We've tried the detailed steps without result.

The database query doesn't have any result:

# su - postgres

-bash-4.1$ psql engine -c "select fn_db_add_config_value ('HostedEngineStorageDomainName', 'hosted_storage', 'general');"

fn_db_add_config_value

------------------------
 
(1 row)



Also, the engine config seems not to have the indicated key (HostedEngineStorageDomainName). The only two keys it reports are these:

# engine-config -l | grep Hosted

HostedEngineVmName: The name of the Hosted Engine VM. That name will be used to perform exclusive operation by ovirt-engine on that VM. (Value Type: String)

AutoImportHostedEngine: "Try to automatically import the hosted engine VM and its storage domain" (Value Type: Boolean)



The attempt of adding the HostedEngineStorageDomainName key finish with the following error:

# echo HostedEngineStorageDomainName | engine-config  -s HostedEngineStorageDomainName="stg-data-fc-he-0001" -p /dev/stdin

Key for add operation must be defined!
Comment 6 Roy Golan 2016-02-12 05:00:26 EST
(In reply to Sistemas Amtega from comment #5)
> Hello,
> 
> We've tried the detailed steps without result.
> 
> The database query doesn't have any result:
> 
> # su - postgres
> 
> -bash-4.1$ psql engine -c "select fn_db_add_config_value
> ('HostedEngineStorageDomainName', 'hosted_storage', 'general');"
> 
> fn_db_add_config_value
> 
> ------------------------
>  
> (1 row)
> 
> 

It looks like the command exited successfully (it says '(1 row)')

> 
> Also, the engine config seems not to have the indicated key
> (HostedEngineStorageDomainName). The only two keys it reports are these:
> 
> # engine-config -l | grep Hosted

the -l is reading a list of key from a file. Thats why I supplied the usage of /dev/stdin as an alternative key file ( the -p usage) 
> 

> HostedEngineVmName: The name of the Hosted Engine VM. That name will be used
> to perform exclusive operation by ovirt-engine on that VM. (Value Type:
> String)
> 
> AutoImportHostedEngine: "Try to automatically import the hosted engine VM
> and its storage domain" (Value Type: Boolean)
> 
> 
> 
> The attempt of adding the HostedEngineStorageDomainName key finish with the
> following error:
> 
> # echo HostedEngineStorageDomainName | engine-config  -s
> HostedEngineStorageDomainName="stg-data-fc-he-0001" -p /dev/stdin
> 
> Key for add operation must be defined!

Ok, try this -
 HostedEngineStorageDomainName= | engine-config  -s HostedEngineStorageDomainName="stg-data-fc-he-0001" -p /dev/stdin

The only difference is the '=' sign at the echo part.
Comment 7 Roy Golan 2016-02-12 05:01:09 EST
needinfo
Comment 8 Sistemas Amtega 2016-02-15 03:49:35 EST
Hello,

We tried the new command without success. The result was this:

# HostedEngineStorageDomainName= | engine-config -s HostedEngineStorageDomainName="stg-data-fc-he-0001" -p /dev/stdin

Error setting HostedEngineStorageDomainName's value. No such entry with version general.
Comment 9 Roy Golan 2016-02-17 06:33:02 EST
We support the default hosted_storage name for now. Please see Bug 1294457. 

After a clean, zoned setup you will see the options above mentioned.
Comment 10 Sistemas Amtega 2016-02-17 06:53:00 EST
We think that in this case the correct action is to close this bugs as duplicated of 1294457. The reason is that is clear that is a bug because the hosted engine setup asks for this name and if you change the default proposed value (hosted_storage) the process doesn't work.
Comment 11 Doron Fediuck 2016-03-20 06:02:05 EDT
Hi,
Bug 1294457 is irrelevant in this context as it is caused by multiple hosted-engine installation using the same iSCSI storage.
The current issue is handled by Bug 1303716 which will not block the option to use a different name.

*** This bug has been marked as a duplicate of bug 1303716 ***

Note You need to log in before you can comment on or make changes to this bug.