Bug 1303716 - changing HE storage domain name causes HE storage and VM import failure
changing HE storage domain name causes HE storage and VM import failure
Status: CLOSED CURRENTRELEASE
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General (Show other bugs)
1.3.2.3
x86_64 Linux
high Severity high (vote)
: ovirt-3.6.3
: 1.3.3.1
Assigned To: Simone Tiraboschi
Artyom
: Triaged
: 1304612 (view as bug list)
Depends On:
Blocks: 1305885
  Show dependency treegraph
 
Reported: 2016-02-01 13:08 EST by Peter Lannigan
Modified: 2017-05-11 05:25 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The engine identifies the hosted-engine storage domain by its name so let the user changing it can break this flow. Removing the question about hosted-engine storage domain name from hosted-engine-setup
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:09:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: exception+
ylavi: planning_ack+
dfediuck: devel_ack+
gklein: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 52979 master MERGED storage: avoid asking about storage domain and storage pool name 2016-02-08 08:38 EST
oVirt gerrit 53223 ovirt-hosted-engine-setup-1.3 MERGED storage: avoid asking about storage domain and storage pool name 2016-02-08 09:57 EST

  None (edit)
Description Peter Lannigan 2016-02-01 13:08:52 EST
Description of problem:
The 'hosted-engine --deploy' script prompts for the storage domain name for the HE.  If you change the name from the default (hosted_engine) then other components cannot find the HE storage to import the storage and VM. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run 'hosted-engine --deploy'
2. Change the storage domain name to 'he_storage' when prompted
3. 

Actual results:
The install completes and the system runs but there are various errors about not being able to import the HE storage domain nor the HE VM.  You can import the storage domain, the system just doesn't recognize that its the HE storage domain.

Expected results:
The other components should know about the name change and import the HE storage and VM properly.

Additional info:
If you import the HE storage domain and then rename it to the default of 'hosted_storage' everything suddenly works and the HE VM is imported.

Suggestion:
Don't let the users change the name at install time (just tell them what its going to be) OR fix the hard-coded values else where in the code.  Seems to me either would be fine.
Comment 1 Sandro Bonazzola 2016-02-02 05:53:23 EST
Proposed solution is to drop the possibility to change the storage domain name while deploying the host.
Comment 2 Simone Tiraboschi 2016-02-02 06:05:10 EST
Then we need also to add a CanDoAction to prevent the user editing the hosted-engine storage domain name from the WebUI.
Comment 3 Roy Golan 2016-02-02 07:41:46 EST
(In reply to Simone Tiraboschi from comment #2)
> Then we need also to add a CanDoAction to prevent the user editing the
> hosted-engine storage domain name from the WebUI.

I'm against this proposed solution of removig the name change completely. 

Peter please see Bug 1294457 for some reference.
Comment 4 Yaniv Lavi (Dary) 2016-02-03 03:51:15 EST
(In reply to Roy Golan from comment #3)
> (In reply to Simone Tiraboschi from comment #2)
> > Then we need also to add a CanDoAction to prevent the user editing the
> > hosted-engine storage domain name from the WebUI.
> 
> I'm against this proposed solution of removig the name change completely. 
> 
> Peter please see Bug 1294457 for some reference.

Please block this for 3.6.3 and we can consider allowing change of name once the above bug is fixed.
Comment 5 Yaniv Lavi (Dary) 2016-02-03 03:52:33 EST
Please block this option of the UI\API side.
Comment 6 Roy Golan 2016-02-03 04:10:54 EST
(In reply to Yaniv Dary from comment #5)
> Please block this option of the UI\API

There is a workaround for that[1]. I don't think should be blocked.

[1]  engine-config -s HostedEngineStorageDomainName=he_storage  && service restart ovirt-engine
Comment 7 Yaniv Lavi (Dary) 2016-02-03 05:32:38 EST
Is this going to be fixed for 3.6.3? Or these it depend on Bug 1294457?
Comment 8 Peter Lannigan 2016-02-04 19:25:50 EST
As the original requester my preference would be to avoid having additional set up commands to run as getting hosted-engine up and going is a bit involved already.  If the necessary 'engine-config' command can be worked into the 'hosted-engine --deploy' script that would be good.  Please either automate the name change or block it.
Comment 9 Roy Golan 2016-02-07 07:51:34 EST
Before fixing Bug 1294457 we must revert that fix.
Comment 10 Simone Tiraboschi 2016-02-08 08:28:01 EST
(In reply to Roy Golan from comment #9)
> Before fixing Bug 1294457 we must revert that fix.

ok
Comment 11 Roy Golan 2016-02-10 04:31:08 EST
(In reply to Yaniv Dary from comment #5)
> Please block this option of the UI\API side.

this would be blocked in installation so its invisible for fresh install. someone is upgrading with a differnt name we still want to let him remedy the situation by using the engine-config I added in 3.6.3
Comment 12 Yaniv Lavi (Dary) 2016-02-14 08:17:03 EST
(In reply to Roy Golan from comment #11)
> (In reply to Yaniv Dary from comment #5)
> > Please block this option of the UI\API side.
> 
> this would be blocked in installation so its invisible for fresh install.
> someone is upgrading with a differnt name we still want to let him remedy
> the situation by using the engine-config I added in 3.6.3

I have no problem with engine-config, only with changing the name in the UI, if this is not blocked.
Comment 13 Artyom 2016-02-17 11:32:51 EST
Checked on ovirt-hosted-engine-setup-1.3.3.3-1.el7ev.noarch
Now it not possible to change HE storage domain via interactive mode, but still possible to do it via answerfile.
Also what about comment 8?
I believe it possible to add to cloud-init configuration:
engine-config -s HostedEngineStorageDomainName=custom_he_storage_domain_name
service restart ovirt-engine
Comment 14 Simone Tiraboschi 2016-02-17 11:58:41 EST
(In reply to Artyom from comment #13)
> Checked on ovirt-hosted-engine-setup-1.3.3.3-1.el7ev.noarch
> Now it not possible to change HE storage domain via interactive mode, but
> still possible to do it via answerfile.

Yes, it's intentional.

> Also what about comment 8?
> I believe it possible to add to cloud-init configuration:
> engine-config -s HostedEngineStorageDomainName=custom_he_storage_domain_name
> service restart ovirt-engine

Yes, but it would not work for who will use the automated flow with cloud-init.
Comment 15 Artyom 2016-02-18 04:11:47 EST
Verified on ovirt-hosted-engine-setup-1.3.3.3-1.el7ev.noarch
See comments 13 and 14
Comment 16 Doron Fediuck 2016-03-20 06:02:05 EDT
*** Bug 1304612 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.