Bug 1304648 - Can't connect to any display if specifying nothing to monitor-mapping
Can't connect to any display if specifying nothing to monitor-mapping
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.8
x86_64 Unspecified
medium Severity medium
: rc
: ---
Assigned To: Pavel Grunt
Virtualization Bugs
:
Depends On:
Blocks: 1339491 1339500
  Show dependency treegraph
 
Reported: 2016-02-04 04:25 EST by xiaodwan
Modified: 2016-05-25 04:13 EDT (History)
11 users (show)

See Also:
Fixed In Version: virt-viewer-2.0-14.el6
Doc Type: Bug Fix
Doc Text:
Cause: An empty monitor-mapping was being parsed. Consequence: Can't connect to any display when an empty monitor-mapping was parsed. Fix: Return early when parsing an empty monitor-mapping, using the "fallback" mapping then. Result: virt-viewer ignores the empty monitor-mapping and connects using the "fallback" one.
Story Points: ---
Clone Of:
: 1339491 (view as bug list)
Environment:
Last Closed: 2016-05-10 17:22:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xiaodwan 2016-02-04 04:25:20 EST
Description of problem:
Can't connect to any display if specifying nothing to monitor-mapping.

Version-Release number of selected component (if applicable):
virt-viewer-2.0-13.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Set monitor-mapping to blank string.
# cat .config/virt-viewer/settings 

#rhel7.2-back-clone
[d622b6f8-fdee-ad9c-63fe-cac2e9b6200d]
monitor-mapping=
2. Wait for the guest startup and Login into the guest first.
3. lanuch virt-viewer with -f arguments.
# virt-viewer rhel7.2-back-clone -f


Actual results:
"Connected to graphic sever" screen displays and can't connect to any display.


Expected results:
virt-viewer should ignore the monitor-mapping settings and connect to correct displays.

Additional info:
This issue doesn't occur on rhel7.2.
Comment 2 Fabiano Fidêncio 2016-02-10 05:11:44 EST
We already had this discussion, more than once, but why the tests are being done using root instead of a normal user? :-\
Comment 3 xiaodwan 2016-02-13 21:51:46 EST
(In reply to Fabiano Fidêncio from comment #2)
> We already had this discussion, more than once, but why the tests are being
> done using root instead of a normal user? :-\

Hi, I tested this problem with root user and normal user. Both of them have same problem.
Comment 8 xiaodwan 2016-03-07 02:23:52 EST
Hi fidencio, 

For this bug, the empty value problem is resolved.

But if specify <CLIENT_MONITOR-ID> greater than the real monitor count, it still can't connect to any display. 

#rhel7.2-back-clone
[d622b6f8-fdee-ad9c-63fe-cac2e9b6200d]
monitor-mapping=1:5 

Should i file a new bug for it or just change the status of this bug? 

Thanks
Comment 9 xiaodwan 2016-03-07 04:25:21 EST
According comment 8, this bug is fixed. and filed a new bug for another problem.
https://bugzilla.redhat.com/show_bug.cgi?id=1315206

So move this bug from ON_QA to VERIFIED.
Comment 11 errata-xmlrpc 2016-05-10 17:22:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0832.html

Note You need to log in before you can comment on or make changes to this bug.