Bug 1304681 - Journal spam: Gdk-WARNING **: gdk-frame-clock: layout continuously requested, giving up after 4 tries
Summary: Journal spam: Gdk-WARNING **: gdk-frame-clock: layout continuously requested,...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
: 1309752 1314386 (view as bug list)
Depends On:
Blocks: F24FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2016-02-04 10:49 UTC by Vít Ondruch
Modified: 2017-04-06 17:40 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-04 15:36:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 758893 None None None 2016-02-04 10:49:07 UTC

Description Vít Ondruch 2016-02-04 10:49:08 UTC
Description of problem:
My journal is continuously spammed with messages such as:

$ journalctl -f
-- Logs begin at Sun 2014-06-01 03:10:01 CEST. --
Dec 01 11:53:29 localhost org.gnome.Shell.desktop[2211]: (gnome-shell:2211): Gdk-WARNING **: gdk-frame-clock: layout continuously requested, giving up after 4 tries
Dec 01 11:53:29 localhost org.gnome.Shell.desktop[2211]: (gnome-shell:2211): Gdk-WARNING **: gdk-frame-clock: layout continuously requested, giving up after 4 tries
Dec 01 11:53:29 localhost org.gnome.Shell.desktop[2211]: (gnome-shell:2211): Gdk-WARNING **: gdk-frame-clock: layout continuously requested, giving up after 4 tries
Dec 01 11:53:29 localhost org.gnome.Shell.desktop[2211]: (gnome-shell:2211): Gdk-WARNING **: gdk-frame-clock: layout continuously requested, giving up after 4 tries
Dec 01 11:53:29 localhost org.gnome.Shell.desktop[2211]: (gnome-shell:2211): Gdk-WARNING **: gdk-frame-clock: layout continuously requested, giving up after 4 tries
^C

Would be nice to fix this.



Version-Release number of selected component (if applicable):
$ rpm -q gnome-shell
gnome-shell-3.19.2-1.fc24.x86_64

$ rpm -q gtk3
gtk3-3.19.3-2.fc24.x86_64



How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Fedora Blocker Bugs Application 2016-02-04 10:55:39 UTC
Proposed as a Blocker for 24-final by Fedora user vondruch using the blocker tracking app because:

 Although gnome-shell is not exactly application, it is constantly spamming journal and hence increases disk and cpu load. 

"All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test."

Link:
https://fedoraproject.org/wiki/Fedora_24_Final_Release_Criteria#Default_application_functionality

Comment 2 Stephen Gallagher 2016-02-08 16:45:38 UTC
This does not meet that criterion even slightly. Log spew does not mean it fails basic functionality.

-1 Blocker

Comment 3 Andrew Cook 2016-02-09 05:37:26 UTC
"A bug in a Critical Path package that:
  * Cannot be fixed with a future stable update
  * Has a severity rating of high or greater and no reasonable workaround (see definition of severity and priority)"

gnome-shell is a critical-path package, and while this could be fixed in the future, it not only makes the user journal large and useless, it consumes substantial cpu power doing so with no reasonable workaround

Comment 4 Stephen Gallagher 2016-02-09 11:58:39 UTC
(In reply to Andrew Cook from comment #3)
> "A bug in a Critical Path package that:
>   * Cannot be fixed with a future stable update

This is the part that would qualify it as a blocker. Also, I don't know anyone who would consider log noise as having a severity rating of "high or greater".

Comment 5 Andrew Cook 2016-02-10 23:06:25 UTC
It's the cpu usage more than journal spam, it's more than halved my battery life

Comment 6 Colin Guthrie 2016-02-12 09:11:40 UTC
This seems related to multi-monitor on my system (Dell XPS13 Intel Ivybridge Mobile). When the 2nd monitor is unplugged, gnome-shell is fine, but plug it in and I get this problem.

Comment 7 Chris Murphy 2016-02-15 07:03:13 UTC
Any regressive behavior that cuts battery life in half is unsuitable for final release. If it's reproducible, widespread, with no work around, I'd say it violates "Bug hinders execution of required Alpha test plans or dramatically reduces test coverage" and make it alpha or beta blocking; I'd certainly curtail my testing given such behavior. It's just not worth dealing with.

If it's happening only with 2+ displays attached, that sounds like a conditional blocker and perhaps comes down to a judgement call or votes at a later time. But I think it'd be unwise to ship a final release with 15% less battery life, let alone 50%. That's not a feature.

Comment 8 Colin Guthrie 2016-02-15 09:04:35 UTC
I retract my 2+ displays statement. Like the other testers on the upstream bug, it happens under other conditions also. Sorry for the noise and false debug path.

Comment 9 Petr Schindler 2016-02-15 17:55:38 UTC
Discussed at 2016-02-15 blocker review meeting: [1]. 

We decided to punt the decision - this is a difficult judgement call and it's hard to make it with only a few (mostly QA) folks in attendance

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2016-02-15/f24-blocker-review.2016-02-15-17.00.html

Comment 10 Petr Schindler 2016-02-22 19:23:51 UTC
Discussed at 2016-02-22 blocker review meeting: [1]. 

This bug was accepted as Final blocker: this is considered a violation of "All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use", in that the Shell is the core of the "default panel" for Workstation and constantly spamming the system logs and consuming significant resources constitutes failing to "function correctly"

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2016-02-22/f24-blocker-review.2016-02-22-17.00.html

Comment 11 Kamil Páral 2016-02-23 08:03:43 UTC
The upstream bug got closed, hopefully fixed. Now we need an update for Fedora.

Comment 12 Jan Kurik 2016-02-24 14:24:18 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Comment 13 Matthias Clasen 2016-03-03 17:56:08 UTC
still happening

Comment 14 Florian Müllner 2016-03-04 12:34:37 UTC
*** Bug 1314386 has been marked as a duplicate of this bug. ***

Comment 15 Florian Müllner 2016-03-04 12:35:03 UTC
*** Bug 1309752 has been marked as a duplicate of this bug. ***

Comment 16 Matthias Clasen 2016-03-14 12:52:04 UTC
I've put workarounds for this in the gtk packages (gtk2 and gtk3)

Comment 17 Vít Ondruch 2016-03-14 13:07:28 UTC
(In reply to Matthias Clasen from comment #16)
> I've put workarounds for this in the gtk packages (gtk2 and gtk3)

Can I test them? What are the versions? Or are they in Fedora already, since the situation looks to be much better now:

$ rpm -q gtk3
gtk3-3.19.11-1.fc25.x86_64

$ uptime
 14:05:57 up  4:42,  1 user,  load average: 0,68, 0,40, 0,34

$ journalctl -b | grep frame-clock | wc -l
18

Comment 18 Matthias Clasen 2016-03-14 14:09:08 UTC
the workaround is in 2.24.30 and will be in 3.19.12

Comment 19 Matthias Clasen 2016-04-04 15:36:54 UTC
should be fixed now. Please reopen if you still see it with post-alpha f24

Comment 20 emilbarton 2017-01-14 15:19:11 UTC
Hi, I'd be happy to learn how I could avoid being affected by the same problem in my program (https://github.com/emilbarton/Unidatab). I've been looking for a solution on wxWidgets Discussion Forum (https://forums.wxwidgets.org/viewtopic.php?f=23&t=43009).

Comment 21 Arnaud 2017-04-06 17:40:10 UTC
It happens on one of my system, when using filezilla.

f25, mate, x86_64. Only 1 screen


Note You need to log in before you can comment on or make changes to this bug.