Bug 1304815 - Non-admin user can not add or Remove Host Collection to or from Activation Key.
Non-admin user can not add or Remove Host Collection to or from Activation Key.
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Users & Roles (Show other bugs)
6.1.5
x86_64 Linux
high Severity medium (vote)
: 6.2.5
: --
Assigned To: Brad Buckingham
jcallaha
: Triaged
: 1384728 1404474 (view as bug list)
Depends On:
Blocks: 1316897 1394389
  Show dependency treegraph
 
Reported: 2016-02-04 12:05 EST by Prakash Ghadge
Modified: 2017-02-06 03:54 EST (History)
17 users (show)

See Also:
Fixed In Version: tfm-rubygem-katello-3.0.0.86-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1394389 (view as bug list)
Environment:
Last Closed: 2016-12-12 12:10:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
verification screenshot (60.22 KB, image/png)
2016-12-01 16:01 EST, jcallaha
no flags Details
role permissions (23.33 KB, image/png)
2016-12-01 16:02 EST, jcallaha
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 16997 None None None 2016-10-18 11:28 EDT

  None (edit)
Description Prakash Ghadge 2016-02-04 12:05:58 EST
Description of problem:

When logging on with a non admin user with an role with all rights on Activation Key and Host Collections, it is not possible to Add or Remove Host Collections from Activation Keys. The add or remove button is not present.


Version-Release number of selected component (if applicable):

Satellite 6.1

How reproducible:

Always

Steps to Reproduce:
User logged on to Satellite webinterface with:
   - No admin rights
   - Role assigned with:
      - create_activation_keys, edit_activation_keys, destroy_activation_keys, view_activation_keys permissions on Activation Keys
      - view_host_collections, create_host_collections, edit_host_collections, destroy_host_collections on Host Collections
- Navigate to: Content --> Activation Keys --> Select existing Activation Key --> TAB Host Collections
- No Add or Remove button is visible to be able to add or remove host collections from the Activation Key, 


Actual results:

No add or remove button.

Expected results:

webUI should provide add and remove button for non-admin user.
Comment 5 jnikolak 2016-10-13 21:40:12 EDT
*** Bug 1384728 has been marked as a duplicate of this bug. ***
Comment 8 Brad Buckingham 2016-10-18 11:28:39 EDT
Created redmine issue http://projects.theforeman.org/issues/16997 from this bug
Comment 9 Brad Buckingham 2016-10-18 11:48:13 EDT
Proposed fix in Katello PR: https://github.com/Katello/katello/pull/6402
Comment 10 jnikolak 2016-10-19 22:33:07 EDT
I tested this under Satellite 6.1.10
Customer tested this under Satellite 6.2.2
--> foreman-1.11.0.53-1.el7sat.noarch


He has also reported that subscriptions are not showing up (which is a more major defect) when using a non-admin role.

When using an admin role, the subscriptions do show.
I'm currently verifying if I'm seeing the situation with roles on my Satellite.
Comment 11 jnikolak 2016-10-20 20:10:21 EDT
In 6.2.2 I've confirmed that if you add all Roles, or specify a Role with everything, that there isn't a way to view the subscription inside the activation key.

Is it possible to get the missing subscription inside the activation key also resolved.
Comment 12 Brad Buckingham 2016-10-21 15:06:03 EDT
It looks like the issue raised by comment 10 and 11 has already been addressed by bug 1333219.  If it is Ok, we'll keep this one focused on the initial issue raised for host collections.
Comment 13 jnikolak 2016-11-13 18:21:20 EST
Yes it will be fine to focus on host collections.
Comment 18 jcallaha 2016-12-01 16:00:35 EST
Verified in Satellite 6.2.5

Create a user with only the required permissions and was able to successfully view/add/remove host collections from the activation key. see attached screenshots
Comment 19 jcallaha 2016-12-01 16:01 EST
Created attachment 1227015 [details]
verification screenshot
Comment 20 jcallaha 2016-12-01 16:02 EST
Created attachment 1227016 [details]
role permissions
Comment 22 errata-xmlrpc 2016-12-12 12:10:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:2940
Comment 23 Stuart Auchterlonie 2016-12-13 18:20:25 EST
*** Bug 1404474 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.