Bug 1304833 - OOTB Self Service roles don't have access to Services tab
OOTB Self Service roles don't have access to Services tab
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.6.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Dan Clarizio
Satyajit Bulage
: ZStream
Depends On:
Blocks: 1306672
  Show dependency treegraph
 
Reported: 2016-02-04 12:57 EST by Dan Clarizio
Modified: 2016-07-27 02:36 EDT (History)
5 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1306672 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:36:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Clarizio 2016-02-04 12:57:57 EST
Description of problem:
The user_self_service and user_limited_self_service roles were designed before Services were in the product, for these users to provision and manager their own VMs and Instances.  Should we add the pertinent Services tabs to these roles are do we need new roles for Service based users?

Version-Release number of selected component (if applicable):
5.6.0

How reproducible:
Login as self service user, can't see any services

Additional info:
Will ask PM how to proceed.
Comment 6 CFME Bot 2016-02-11 12:46:27 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/d3a7f513c266daec1bcc636169088559140403c3

commit d3a7f513c266daec1bcc636169088559140403c3
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Mon Feb 8 14:41:08 2016 -0800
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Mon Feb 8 14:41:08 2016 -0800

    Add Services features to OOTB self_service roles
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1304833

 db/fixtures/miq_user_roles.yml | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
Comment 8 CFME Bot 2016-02-15 10:42:37 EST
Detected commit referencing this ticket while ticket status is MODIFIED.
Comment 9 CFME Bot 2016-04-14 17:26:19 EDT
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=6e0d7814502f57ebca9c2bdfdb826113b2b641e0

commit 6e0d7814502f57ebca9c2bdfdb826113b2b641e0
Merge: 5574b17 bd22cd2
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Thu Apr 14 16:48:43 2016 -0400
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Thu Apr 14 16:48:43 2016 -0400

    Merge branch '55z_pr_6561' into '5.5.z'
    
    Add Services features to OOTB self_service roles
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1304833
    https://bugzilla.redhat.com/show_bug.cgi?id=1306672
    (cherry picked from commit d3a7f51)
    
    @dclarizi please review/merge, clean cherry-pick for https://github.com/ManageIQ/manageiq/pull/6561
    
    See merge request !862

 db/fixtures/miq_user_roles.yml | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
Comment 10 CFME Bot 2016-04-14 17:26:52 EDT
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=bd22cd21b720b8bdc90787014d38518691e02429

commit bd22cd21b720b8bdc90787014d38518691e02429
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Mon Feb 8 17:41:08 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Thu Mar 17 17:14:01 2016 -0400

    Add Services features to OOTB self_service roles
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1304833
    https://bugzilla.redhat.com/show_bug.cgi?id=1306672
    (cherry picked from commit d3a7f51)

 db/fixtures/miq_user_roles.yml | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
Comment 11 Satyajit Bulage 2016-04-25 08:14:33 EDT
Verified that Self Service roles have access to Services tab
Verified Version:- 5.6.0.4-beta2.3.20160421172650_719e256
Comment 13 errata-xmlrpc 2016-06-29 11:36:20 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.