This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1304886 - Incremental update using cli does not update systems when --update-all-systems=true is passed
Incremental update using cli does not update systems when --update-all-system...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Errata Management (Show other bugs)
6.1.6
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: John Mitsch
: PrioBumpQA, Regression, Triaged
Depends On:
Blocks: 1315278
  Show dependency treegraph
 
Reported: 2016-02-04 16:59 EST by sthirugn@redhat.com
Modified: 2017-03-27 13:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1315278 (view as bug list)
Environment:
Last Closed: 2017-03-27 13:12:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sthirugn@redhat.com 2016-02-04 16:59:44 EST
Description of problem:
Incremental update using cli does not update systems when --update-all-systems=true is passed

Version-Release number of selected component (if applicable):
Sat 6.1.6

How reproducible:
Always

Steps to Reproduce:
hammer > content-view version incremental-update --content-view-version-id=4 --errata-ids=a8e3bdf7-b147-4922-87fa-771ea0cc2ea3 --environment-ids=2 --update-all-systems=true

Actual results:
The incremental update finished but the systems are not updated

Expected results:
The incremental update finished but the systems are updated

Additional info:
Comment 3 sthirugn@redhat.com 2016-02-04 17:30:27 EST
There are no errors shown at all.  It looks like --update-all-systems=true is silently ignored.
Comment 5 John Mitsch 2016-08-18 14:43:18 EDT
Created redmine issue http://projects.theforeman.org/issues/16180 from this bug
Comment 6 John Mitsch 2016-08-22 10:43:57 EDT
A fix went in for this in 6.2, but will not merge cleanly to 6.1, changing the status back to new

https://bugzilla.redhat.com/show_bug.cgi?id=1315278
Comment 7 Bryan Kearney 2017-03-27 13:12:39 EDT
We do not plan on fixing this for Satellite 6.1. I am closing this out as WONTFIX. If you feel this was done in error, please feel free to re-open with additional information. This is fixed in 6.2.

Note You need to log in before you can comment on or make changes to this bug.