Bug 1315278 - Incremental update using cli does not update systems when --update-all-systems=true is passed
Incremental update using cli does not update systems when --update-all-system...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Errata Management (Show other bugs)
6.1.6
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: --
Assigned To: Justin Sherrill
jcallaha
http://projects.theforeman.org/issues...
: PrioBumpQA, Regression, Triaged
Depends On: 1304886 1323726
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 06:59 EST by Brad Buckingham
Modified: 2016-07-27 05:26 EDT (History)
7 users (show)

See Also:
Fixed In Version: rubygem-katello-3.0.0.15-1,gofer-2.7.6-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1304886
Environment:
Last Closed: 2016-07-27 05:26:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14336 None None None 2016-04-22 13:01 EDT

  None (edit)
Comment 3 Justin Sherrill 2016-03-23 16:43:23 EDT
Created redmine issue http://projects.theforeman.org/issues/14336 from this bug
Comment 4 Bryan Kearney 2016-03-31 16:06:43 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/14336 has been closed
-------------
Justin Sherrill
Applied in changeset commit:katello|d826df47b47bd90cdbecf44545d1c4d8c4958058.
Comment 5 sthirugn@redhat.com 2016-04-11 16:20:36 EDT
Failed in satellite-6.2.0-7.0.beta.el7sat.noarch due to https://bugzilla.redhat.com/show_bug.cgi?id=1323726

hammer> content-view version incremental-update --content-view-version-id=3 --errata-ids=b272b0c4-25cc-4204-bfe1-39de76e6e9ba --update-all-hosts=true --lifecycle-environment-ids=2
[....................................................................      ] [92%]
Comment 6 Mike McCune 2016-04-14 01:04:02 EDT
POST as reflected from the fix found here:


https://bugzilla.redhat.com/show_bug.cgi?id=1323726
Comment 8 jcallaha 2016-04-25 11:17:48 EDT
Verified in Satellite 6.2 Beta Snap 9 Compose 1.

[root@rhsm-qe-1 ~]# hammer content-view version incremental-update --content-view-version-id 70 --update-all-hosts true --lifecycle-environment-ids 1 --errata-ids 318fb337-1d0c-4305-a8e9-dd6788608799
[....................................................................................................................................................................................] [100%]
Content View: beta version 4.1
Added Content:
  Errata:
        RHBA-2016:0178
  Packages:
        cyrus-sasl-2.1.26-20.el7_2.i686
        cyrus-sasl-2.1.26-20.el7_2.x86_64
        cyrus-sasl-devel-2.1.26-20.el7_2.i686
        cyrus-sasl-devel-2.1.26-20.el7_2.x86_64
        cyrus-sasl-gssapi-2.1.26-20.el7_2.i686
        cyrus-sasl-gssapi-2.1.26-20.el7_2.x86_64
        cyrus-sasl-lib-2.1.26-20.el7_2.i686
        cyrus-sasl-lib-2.1.26-20.el7_2.x86_64
        cyrus-sasl-md5-2.1.26-20.el7_2.i686
        cyrus-sasl-md5-2.1.26-20.el7_2.x86_64
        cyrus-sasl-plain-2.1.26-20.el7_2.i686
        cyrus-sasl-plain-2.1.26-20.el7_2.x86_64
        cyrus-sasl-scram-2.1.26-20.el7_2.i686
        cyrus-sasl-scram-2.1.26-20.el7_2.x86_64
Comment 10 errata-xmlrpc 2016-07-27 05:26:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.