Bug 1304933 - ospd-8 poodle 2016-02-04.1 tempest.api.telemetry.test_telemetry_notification_api failing
ospd-8 poodle 2016-02-04.1 tempest.api.telemetry.test_telemetry_notification...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ceilometer (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
high Severity high
: rc
: 10.0 (Newton)
Assigned To: Pradeep Kilambi
Mehdi ABAAKOUK
: Automation, AutomationBlocker, TestOnly, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 20:23 EST by wes hayutin
Modified: 2016-12-14 10:22 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-14 10:22:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2016-02-04 20:23:40 EST
Description of problem:

ospd-8 poodle 2016-02-04.1  tempest.api.telemetry.test_telemetry_notification_api failing

2016-02-04 18:30:06,805 16575 INFO     [tempest_lib.common.rest_client] Request (TelemetryNotificationAPITestJSON:test_check_glance_v1_notifications): 200 GET http://172.16.23.110:8777/v2/meters/image.size?q.op=eq&q.value=d4093716-7d4b-42ca-ade6-22cfb61fdd90&q.field=resource 0.009s
2016-02-04 18:30:06,805 16575 DEBUG    [tempest_lib.common.rest_client] Request - Headers: {'Content-Type': 'application/json', 'Accept': 'application/json', 'X-Auth-Token': '<omitted>'}
        Body: None
    Response - Headers: {'status': '200', 'content-length': '2', 'content-location': 'http://172.16.23.110:8777/v2/meters/image.size?q.op=eq&q.value=d4093716-7d4b-42ca-ade6-22cfb61fdd90&q.field=resource', 'server': 'Werkzeug/0.9.1 Python/2.7.5', 'date': 'Thu, 04 Feb 2016 23:30:06 GMT', 'content-type': 'application/json; charset=UTF-8', 'x-openstack-request-id': 'req-ca0c7f02-f9b1-422a-90e3-0dcb7df10c97'}
        Body: []
}}}

Traceback (most recent call last):
  File "/home/stack/tempest/tempest/test.py", line 127, in wrapper
    return f(self, *func_args, **func_kwargs)
  File "/home/stack/tempest/tempest/api/telemetry/test_telemetry_notification_api.py", line 50, in test_check_glance_v1_notifications
    self.await_samples(metric, query)
  File "/home/stack/tempest/tempest/api/telemetry/base.py", line 131, in await_samples
    CONF.compute.build_timeout))
tempest.exceptions.TimeoutException: Request timed out
Details: Sample for metric:image.size with query:('resource', 'eq', u'd4093716-7d4b-42ca-ade6-22cfb61fdd90') has not been added to the database within 300 seconds
Comment 2 wes hayutin 2016-02-04 20:26:12 EST
tempest tests failing

-tempest.api.telemetry.test_telemetry_notification_api
Comment 3 wes hayutin 2016-02-04 20:26:19 EST
tempest tests failing

-tempest.api.telemetry.test_telemetry_notification_api
Comment 4 Yurii Prokulevych 2016-02-10 08:00:09 EST
Looks like this BZ 1299563
Comment 5 Pradeep Kilambi 2016-02-24 13:22:09 EST
patch submitted upstream tripleo:

https://review.openstack.org/#/c/283686/
Comment 6 Mike Burns 2016-04-07 17:07:13 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 8 Mehdi ABAAKOUK 2016-10-20 09:40:14 EDT
The tempest itself doesn't exists anymore because Ceilometer sample-api is disable in OSP10.

On a fresh OSPd 10.0, the messaging is correcly configured
$ sudo grep ^driver /etc/nova/nova.conf 
driver=messagingv2

Also during the test plan ran for rhbz#1366721, we have assert that we receive the nova notification in Gnocchi (the new backend for ceilometer), so the feature work as expected now.

If the ceilometer backend is manually setuped to the old mongodb one, the tempest will now pass too.
Comment 10 errata-xmlrpc 2016-12-14 10:22:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html

Note You need to log in before you can comment on or make changes to this bug.