Bug 1304973 - virtio-win 1.7.4 doesn't provide windows 10 drivers within vfd [rhel-6.9]
virtio-win 1.7.4 doesn't provide windows 10 drivers within vfd [rhel-6.9]
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.7
Unspecified Unspecified
high Severity high
: rc
: 6.7
Assigned To: Yash Mankad
Virtualization Bugs
: ZStream
Depends On:
Blocks: 1306586 1300959 1328275 1357128 1379564
  Show dependency treegraph
 
Reported: 2016-02-05 02:37 EST by Sandro Bonazzola
Modified: 2017-03-20 23:59 EDT (History)
30 users (show)

See Also:
Fixed In Version: virtio-win-1.8.0-1.el6
Doc Type: Enhancement
Doc Text:
the virtio-win package now contains the updated Windows Server 2016 drivers in virtual floppy drive (VFD) and ISO image files, and the updated Windows 10 drivers in virtual floppy drive (VFD) files. As a result, the driver does not have to be downloaded manually.
Story Points: ---
Clone Of: 1300959
: 1328275 1357128 (view as bug list)
Environment:
Last Closed: 2017-03-20 23:59:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sandro Bonazzola 2016-02-05 02:37:41 EST
+++ This bug was initially created as a clone of Bug #1300959 +++

Description of problem:

--- Additional comment from Jiri Belka on 2016-02-04 04:05:40 EST ---

Windows 10 drivers exist only on iso, they do neither exist on vfd or as "normal" files of the rpm:

$ rpm -qlp virtio-win-1.7.4-1.el6_7.2.noarch.rpm | egrep '/Win[^\/]*$'
/usr/share/virtio-win/drivers/amd64/Win2003
/usr/share/virtio-win/drivers/amd64/Win2008
/usr/share/virtio-win/drivers/amd64/Win2008R2
/usr/share/virtio-win/drivers/amd64/Win2012
/usr/share/virtio-win/drivers/amd64/Win2012R2
/usr/share/virtio-win/drivers/amd64/Win7
/usr/share/virtio-win/drivers/amd64/Win8
/usr/share/virtio-win/drivers/amd64/Win8.1
/usr/share/virtio-win/drivers/i386/Win2003
/usr/share/virtio-win/drivers/i386/Win2008
/usr/share/virtio-win/drivers/i386/Win7
/usr/share/virtio-win/drivers/i386/Win8
/usr/share/virtio-win/drivers/i386/Win8.1
/usr/share/virtio-win/drivers/i386/WinXP

$ rpm -qlp virtio-win-1.7.4-1.el6_7.2.noarch.rpm | egrep '\.(iso|vfd)$'
/usr/share/virtio-win/virtio-win-1.7.4.iso
/usr/share/virtio-win/virtio-win-1.7.4_amd64.vfd
/usr/share/virtio-win/virtio-win-1.7.4_x86.vfd
/usr/share/virtio-win/virtio-win.iso
/usr/share/virtio-win/virtio-win_amd64.vfd
/usr/share/virtio-win/virtio-win_x86.vfd

$ for f in virtio-win-1.7.4.iso virtio-win-1.7.4_amd64.vfd virtio-win-1.7.4_x86.vfd ; do 7z l $f | egrep -i 'w(in)*10$' | while read l ; do echo $f $l ; done ; done 
virtio-win-1.7.4.iso 2015-10-08 20:06:44 D.... Balloon/w10
virtio-win-1.7.4.iso 2015-10-08 20:06:44 D.... NetKVM/w10
virtio-win-1.7.4.iso 2015-10-08 20:06:44 D.... viorng/w10
virtio-win-1.7.4.iso 2015-10-08 20:06:44 D.... vioscsi/w10
virtio-win-1.7.4.iso 2015-10-08 20:06:44 D.... vioserial/w10
virtio-win-1.7.4.iso 2015-10-08 20:06:44 D.... viostor/w10

So again, most users would install Windows 10 with virtio block device witch attaching vfd with drivers.
Comment 4 lijin 2016-02-13 20:45:36 EST
due to floppy size limitation,win10 drivers are not included in floppy file,QE announced it in bug1274123 during rhel7.2,just mark it here.
Comment 6 Cole Robinson 2016-02-29 14:15:10 EST
The script changes are upstream now:

https://github.com/crobinso/virtio-win-pkg-scripts/commit/6fd31dfbcb30d0dfebafe93e6ef2879e973e6315

So this just needs an internal rebuild to pick it up
Comment 10 Yash Mankad 2016-07-11 17:03:01 EDT
Fixed in virtio-win-1.7.5-1.el6
Comment 15 lijin 2016-10-31 22:45:43 EDT
check in virtio-win-1.8.0-1.el6,windows 10 drivers are included in both virtio-win-1.8.0_amd64.vfd and virtio-win-1.8.0_x86.vfd.

So this issue has been fixed.

Change status to verified.
Comment 17 errata-xmlrpc 2017-03-20 23:59:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0561.html

Note You need to log in before you can comment on or make changes to this bug.