Bug 1305003 - Rawhide (F24) Workstation live sessions use X, not Wayland
Rawhide (F24) Workstation live sessions use X, not Wayland
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
24
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks: WaylandRelated
  Show dependency treegraph
 
Reported: 2016-02-05 04:51 EST by Adam Williamson
Modified: 2016-03-01 04:08 EST (History)
6 users (show)

See Also:
Fixed In Version: gdm-3.19.4.1-4.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 17:13:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of dmesg for GNOME (on Wayland) session inside gnome-boxes (219.42 KB, image/png)
2016-02-29 12:37 EST, Joachim Frieben
no flags Details

  None (edit)
Description Adam Williamson 2016-02-05 04:51:45 EST
I haven't looked into this in detail yet (I'm at devconf and don't have a live image with me), but per multiple reporters in https://bugzilla.redhat.com/show_bug.cgi?id=1281675 , current Rawhide Workstation lives use X.org, even though we're supposed to have made Wayland the 'default' now. I'm throwing this at gdm for now but it may possibly be in spin-kickstarts or something. Just wanted to get it tracked.
Comment 1 Adam Williamson 2016-02-05 04:57:18 EST
I'd set this bug to block the tracker for the Wayland-by-default Change too:

https://fedoraproject.org/wiki/Changes/WaylandByDefault

only it says "Tracker bug: <will be assigned by the Wrangler>". Sigh.
Comment 2 Joachim Frieben 2016-02-05 10:43:01 EST
The findings of https://bugzilla.redhat.com/show_bug.cgi?id=1281675#c47 apply likewise to a system on which the current Fedora development tree has been installed permanently using the network install media.
Thus, as of today, Xwayland belongs to the group of applications comprised of gnome-terminal, nautilus, sealert, etc. which do not start up correctly because of bug 1281675. After a "GNOME on Xorg" session, plain "GNOME" sessions will use Xwayland successfully as expected. Therefore, this bug is redundant.
Comment 3 Joachim Frieben 2016-02-07 12:51:19 EST
As exhibited in comment https://bugzilla.redhat.com/show_bug.cgi?id=1281675#c53 of bug 1281675, GDM appears not set the session type unless it gets changed at the login panel. Simply toggling the session type forth and back allows for a working "GNOME (on Wayland)" session.
By disabling automatic login and setting a password for liveuser before booting into graphical mode, the live system behaves exactly like an installed system.
Comment 4 Ray Strode [halfline] 2016-02-09 12:03:10 EST
this should be fixed in rawhide
Comment 5 Jan Kurik 2016-02-24 10:33:52 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 6 Adam Williamson 2016-02-27 15:31:50 EST
This does not seem to have been fixed. Current F24 Workstation nightlies have gdm-3.19.90-1.fc24, but still seem to be running X, not Wayland. The last F24 Workstation live we have is https://kojipkgs.fedoraproject.org/compose/branched/Fedora-24-20160225.n.0/compose/Workstation/x86_64/iso/Fedora-Live-Workstation-x86_64-Rawhide-20160225.0.iso , you'll have to boot with 'enforcing=0' to get anywhere. It boots to GDM instead of autologging in as it should; if you click 'Live System User' you get an X session. GDM also appears to be running on X.
Comment 7 Joachim Frieben 2016-02-29 02:52:47 EST
(In reply to Adam Williamson from comment #6)
Here, a system with an RV620 based video card boots successfully from a Fedora-Live-Workstation-x86_64-Rawhide-20160225.0 live media with kernel option "enforcing=0" into the default session GNOME (on Wayland) without displaying the login panel.
Comment 8 Adam Williamson 2016-02-29 09:52:37 EST
Hmmm...perhaps there's a difference in behaviour between bare metal with an accelerated video card, and VMs. I *do* get a crash notification for the check-accelerated helper thingy, now I come to think of it. I'll check a bit further (see if I can reproduce Wayland on bare metal) and maybe file a separate bug, thanks.
Comment 9 Joachim Frieben 2016-02-29 12:35:01 EST
(In reply to Adam Williamson from comment #8)
I have just tried the Fedora-Live-Workstation-x86_64-Rawhide-20160225.0 live media again inside gnome-boxes, and it actually boots with kernel option "enforcing=0" into the (flickering) liveuser session using GNOME (on Wayland) - just switch to a virtual console and check the running processes.
Your issue is related to the virtual QXL driver; see attached screenshot of the dmesg output.
Comment 10 Joachim Frieben 2016-02-29 12:37 EST
Created attachment 1131659 [details]
Output of dmesg for GNOME (on Wayland) session inside gnome-boxes
Comment 11 Joachim Frieben 2016-02-29 12:48:24 EST
Actually, I had already stated a week ago in https://bugzilla.redhat.com/show_bug.cgi?id=1308771#c28 in reply to your comment https://bugzilla.redhat.com/show_bug.cgi?id=1308771#c26 that

"1. Current live media boot correctly into GNOME (on Wayland) on bare metal after adding kernel option "enforcing=0". The steps suggested in comment 23 are unnecessary.
2. Current live media boot correctly into GNOME (on Wayland) in a -virtual machine- with kernel option "enforcing=0" but heavy flickering related to a QXL DRM issue (qxl 0000:00:02.0: ... unpin not necessary) makes the the session unusable."
Comment 12 Adam Williamson 2016-02-29 12:51:15 EST
That's nice, but it's not what I see.
Comment 13 Joachim Frieben 2016-02-29 14:02:06 EST
(In reply to Adam Williamson from comment #12)
The host system is current Fedora 23 including packages:
 - gnome-boxes-3.18.1-1.fc23
 - qemu-*-2.4.1.7.fc23
 - libvirt-*-1.2.18.2-2.fc23
 - spice-*-0.30-1.fc23
If you are using an older/different flavour of Fedora/Red Hat this is likely to have an influence ..
Comment 14 Adam Williamson 2016-02-29 14:03:37 EST
I'm running Rawhide. And I don't use Boxes, I use virt-manager.
Comment 15 Adam Williamson 2016-02-29 17:13:06 EST
So indeed I get Wayland booting on real hardware (tested the 2016-02-25 Rawhide Workstation live). The general case is fixed here, looks like there's some specific case with (some) virtual machines, perhaps related to the check-accelerated crasher...let's close this and open a new bug.
Comment 16 Kamil Páral 2016-03-01 04:08:33 EST
Adam, when you file the new bug, can you please link it here? Thanks.

Note You need to log in before you can comment on or make changes to this bug.